1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
4 ;;; This file is part of GNU Guix.
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages gsasl)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages compression)
22 #:use-module (gnu packages libidn)
23 #:use-module (gnu packages nettle)
24 #:use-module (gnu packages shishi)
25 #:use-module (gnu packages tls)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system gnu))
31 (define-public libntlm
37 (uri (string-append "http://www.nongnu.org/libntlm/releases/libntlm-" version
40 "101pr110ardcj2di940g6vaqifsaxc44h6hjn81l63dvmkj5a6ga"))))
41 (build-system gnu-build-system)
42 (synopsis "Library that implements NTLM authentication")
44 "Libntlm is a library that implements NTLM authentication.")
45 (license license:lgpl2.1+)
46 (home-page "http://www.nongnu.org/libntlm/")))
54 (uri (string-append "mirror://gnu/gss/gss-" version
57 "1syyvh3k659xf1hdv9pilnnhbbhs6vfapayp4xgdcc8mfgf9v4gz"))))
58 (build-system gnu-build-system)
59 (inputs `(("nettle" ,nettle)
62 (synopsis "Generic Security Service library")
64 "The GNU Generic Security Service provides a free implementation of the
65 GSS-API specification. It provides a generic application programming
66 interface for programs to access security services. Security services present
67 a generic, GSS interface, with which the calling application interacts via
68 this library, freeing the application developer from needing to know about
69 the underlying security implementation.")
70 (license license:gpl3+)
71 (home-page "http://www.gnu.org/software/gss/")))
79 (uri (string-append "mirror://gnu/gsasl/gsasl-" version
82 "1rci64cxvcfr8xcjpqc4inpfq7aw4snnsbf5xz7d30nhvv8n40ii"))))
83 (build-system gnu-build-system)
84 (inputs `(("libidn" ,libidn)
89 ;; Propagate GnuTLS because libgnutls.la reads `-lnettle', and Nettle is a
90 ;; propagated input of GnuTLS.
91 `(("gnutls" ,gnutls)))
92 (synopsis "Simple Authentication and Security Layer library")
94 "GNU SASL is an implementation of the Simple Authentication and
95 Security Layer framework. On network servers such as IMAP or SMTP servers,
96 SASL is used to handle client/server authentication. This package contains
97 both a library and a command-line tool to access the library.")
98 (license license:gpl3+)
99 (home-page "http://www.gnu.org/software/gsasl/")))