1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
5 ;;; This file is part of GNU Guix.
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20 (define-module (gnu packages graphviz)
21 #:use-module (guix packages)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix download)
24 #:use-module (gnu packages xorg)
25 #:use-module (gnu packages gtk)
26 #:use-module (gnu packages xml)
27 #:use-module (gnu packages glib)
28 #:use-module (gnu packages bison)
29 #:use-module (gnu packages image)
30 #:use-module (gnu packages autotools)
31 #:use-module (gnu packages pkg-config)
32 #:use-module (gnu packages fontutils)
33 #:use-module (gnu packages compression)
34 #:use-module (gnu packages gd)
35 #:use-module ((guix licenses) #:select (lgpl2.0+ epl1.0)))
37 (define-public graphviz
44 "http://www.graphviz.org/pub/graphviz/ARCHIVE/graphviz-"
48 "17l5czpvv5ilmg17frg0w4qwf89jzh2aglm9fgx0l0aakn6j7al1"))))
49 (build-system gnu-build-system)
51 ;; FIXME: rtest/rtest.sh is a ksh script (!). Add ksh as an input.
54 #:phases (alist-cons-before
57 ;; Work around bogus makefile when using an external
58 ;; libltdl. Failing to do so, one hits this error:
59 ;; "No rule to make target `-lltdl', needed by `libgvc.la'."
60 (substitute* "lib/gvc/Makefile"
61 (("am__append_5 *=.*")
65 (lambda* (#:key outputs #:allow-other-keys)
66 (let ((out (assoc-ref outputs "out"))
67 (doc (assoc-ref outputs "doc")))
68 (mkdir-p (string-append doc "/share/graphviz"))
69 (rename-file (string-append out "/share/graphviz/doc")
70 (string-append doc "/share/graphviz/doc"))
74 `(("libXrender" ,libxrender)
77 ("gd" ,gd) ; FIXME: Our GD is too old
79 ("fontconfig" ,fontconfig)
80 ("freetype" ,freetype)
88 ("pkg-config" ,pkg-config)))
89 (outputs '("out" "doc")) ; 5 MiB of html + pdfs
90 (home-page "http://www.graphviz.org/")
91 (synopsis "Graph visualization software")
93 "Graphviz is a graph visualization tool suite. Graph visualization is a
94 way of representing structural information as diagrams of abstract graphs and
95 networks. It has important applications in networking, bioinformatics,
96 software engineering, database and web design, machine learning, and in visual
97 interfaces for other technical domains.")
106 (uri (string-append "mirror://sourceforge/gts/gts-"
110 "07mqx09jxh8cv9753y2d2jsv7wp8vjmrd7zcfpbrddz3wc9kx705"))))
111 (build-system gnu-build-system)
113 '(#:phases (alist-cons-before
116 (chmod "test/boolean/test.sh" #o777))
119 ;; Some data files used by the test suite are missing.
120 ;; See <http://sourceforge.net/p/gts/bugs/41/>.
123 `(("pkg-config" ,pkg-config)))
125 ;; The gts.pc file has glib-2.0 as required.
127 (home-page "http://gts.sourceforge.net/")
129 ;; Note: Despite the name, this is not official GNU software.
130 (synopsis "Triangulated Surface Library")
132 "Library intended to provide a set of useful functions to deal with
133 3D surfaces meshed with interconnected triangles.")