1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
4 ;;; This file is part of GNU Guix.
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages geeqie)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module ((guix licenses) #:prefix l:)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages pkg-config)
25 #:use-module (gnu packages glib)
26 #:use-module (gnu packages gtk)
27 #:use-module (gnu packages image)
28 #:use-module (gnu packages ghostscript)
29 #:use-module (gnu packages compression)
30 #:use-module (gnu packages xml))
32 (define-public exiv2 ; XXX: move elsewhere?
38 (uri (string-append "http://www.exiv2.org/exiv2-"
42 "04bbg2cg6mgcyz435zamx37sp5zw44n2alb59ki1daz71f851yl1"))))
43 (build-system gnu-build-system)
44 (arguments '(#:tests? #f)) ; no `check' target
46 `(("expat" ,expat) ("zlib" ,zlib)))
47 (home-page "http://www.exiv2.org/")
48 (synopsis "Library and command-line utility to manage image metadata")
50 "Exiv2 is a C++ library and a command line utility to manage image
51 metadata. It provides fast and easy read and write access to the Exif, IPTC
52 and XMP metadata of images in various formats.")
54 ;; Files under `xmpsdk' are a copy of Adobe's XMP SDK, licensed under the
55 ;; 3-clause BSD license: <http://www.adobe.com/devnet/xmp/sdk/eula.html>.
56 ;; The core is GPLv2+: <https://launchpad.net/ubuntu/precise/+source/exiv2/+copyright>.
65 (uri (string-append "mirror://sourceforge/geeqie/geeqie-"
69 "1kzy39z9505xkayyx7rjj2wda76xy3ch1s5z35zn8yli54ffhi2m"))))
70 (build-system gnu-build-system)
72 `(;; ("libchamplain" ,libchamplain)
78 `(("intltool" ,intltool)
79 ("pkg-config" ,pkg-config)))
80 (home-page "http://geeqie.sourceforge.net")
81 (synopsis "Lightweight GTK+ based image viewer")
83 "Geeqie is a lightweight GTK+ based image viewer for Unix like operating
84 systems. It features: EXIF, IPTC and XMP metadata browsing and editing
85 interoperability; easy integration with other software; geeqie works on files
86 and directories, there is no need to import images; fast preview for many raw
87 image formats; tools for image comparison, sorting and managing photo
88 collection. Geeqie was initially based on GQview.")