services: avahi: Add Avahi to the system profile.
[guix.git] / gnu / packages / feh.scm
blobee3fcc6b8b87278fe4c9558ba76d62029dc2fde0
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages feh)
20   #:use-module (gnu packages)
21   #:use-module (gnu packages image)
22   #:use-module (gnu packages curl)
23   #:use-module (gnu packages xorg)
24   #:use-module (guix packages)
25   #:use-module (guix download)
26   #:use-module (guix build-system gnu)
27   #:use-module ((guix licenses) #:prefix license:))
29 (define-public feh
30   (package
31     (name "feh")
32     (version "2.14")
33     (home-page "https://feh.finalrewind.org/")
34     (source (origin
35               (method url-fetch)
36               (uri (string-append home-page
37                                   name "-" version ".tar.bz2"))
38               (sha256
39                (base32
40                 "0j5wxpqccnd0hl74z2vwv25n7qnik1n2mcm2jn0c0z7cjn4wsa9q"))))
41     (build-system gnu-build-system)
42     (arguments
43       '(#:phases (alist-delete 'configure %standard-phases)
44         #:tests? #f
45         #:make-flags
46           (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))))
47     (inputs `(("imlib2" ,imlib2)
48               ("curl" ,curl)
49               ("libpng" ,libpng)
50               ("libxt" ,libxt)
51               ("libx11" ,libx11)
52               ("libxinerama" ,libxinerama)))
53     (synopsis "Fast and light imlib2-based image viewer")
54     (description
55       "feh is an X11 image viewer aimed mostly at console users.
56 Unlike most other viewers, it does not have a fancy GUI, but simply
57 displays images.  It can also be used to set the desktop wallpaper.
58 It is controlled via commandline arguments and configurable key/mouse
59 actions.")
61     ;; The license is really the Expat license, with additional wording in the
62     ;; 2nd paragraph: "acknowledgment shall be given in the documentation and
63     ;; software packages that this Software was used."
64     (license (license:x11-style
65               "file://COPYING"
66               "See 'COPYING' in the distribution."))))