1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
4 ;;; This file is part of GNU Guix.
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages dns)
20 #:use-module (gnu packages databases)
21 #:use-module (gnu packages linux)
22 #:use-module (gnu packages perl)
23 #:use-module (gnu packages tls)
24 #:use-module (gnu packages xml)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix build-system gnu))
30 (define-public dnsmasq
37 "http://www.thekelleys.org.uk/dnsmasq/dnsmasq-"
41 "1c80hq09hfm8cp5pirfb8wdlc7dqkp7zzmbmdaradcvlblzx42vx"))))
42 (build-system gnu-build-system)
45 (alist-delete 'configure %standard-phases)
46 #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
50 (home-page "http://www.thekelleys.org.uk/dnsmasq/doc.html")
51 (synopsis "Small caching DNS proxy and DHCP/TFTP server")
53 "Dnsmasq is a lightweight DNS forwarder and DHCP server. It is designed
54 to provide DNS and optionally, DHCP, to a small network. It can serve the
55 names of local machines which are not in the global DNS. The DHCP server
56 integrates with the DNS server and allows machines with DHCP-allocated
57 addresses to appear in the DNS with names configured either in each host or in
58 a central configuration file. Dnsmasq supports static and dynamic DHCP leases
59 and BOOTP/TFTP for network booting of diskless machines.")
60 ;; Source files only say GPL2 and GPL3 are allowed.
61 (license (list license:gpl2 license:gpl3))))
63 (define-public bind-utils
69 (uri (string-append "ftp://ftp.isc.org/isc/bind9/" version
70 "/bind-" version ".tar.gz"))
73 "0pvcnwd4rzfk3l35ys72p14ly9k857wbn1lxzd4ayjk3i2pz1rmi"))))
74 (build-system gnu-build-system)
76 ;; it would be nice to add GeoIP and gssapi once there is package
82 ("p11-kit" ,p11-kit)))
84 `(#:tests? #f ; no test phase implemented
86 (list (string-append "--with-openssl="
87 (assoc-ref %build-inputs "openssl"))
88 (string-append "--with-dlz-mysql="
89 (assoc-ref %build-inputs "mysql"))
90 (string-append "--with-pkcs11="
91 (assoc-ref %build-inputs "p11-kit")))
96 (and (zero? (system* "make" "-C" "lib/dns"))
97 (zero? (system* "make" "-C" "lib/isc"))
98 (zero? (system* "make" "-C" "lib/bind9"))
99 (zero? (system* "make" "-C" "lib/isccfg"))
100 (zero? (system* "make" "-C" "lib/lwres"))
101 (zero? (system* "make" "-C" "bin/dig"))))
104 (lambda _ (zero? (system* "make" "-C" "bin/dig" "install")))
106 (home-page "https://www.isc.org/downloads/bind/")
107 (synopsis "Tools for querying nameservers")
109 "These tools, included with ISC BIND, are useful for analysis of DNS
110 issues or verification of configuration.")
111 (license (list license:isc))))