services: avahi: Add Avahi to the system profile.
[guix.git] / gnu / packages / abduco.scm
blob79865f2211f8d7d7166e1834ad0438592f0c0968
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
19 (define-module (gnu packages abduco)
20   #:use-module (guix build-system gnu)
21   #:use-module (guix download)
22   #:use-module (guix licenses)
23   #:use-module (guix packages))
25 (define-public abduco
26   (package
27    (name "abduco")
28    (version "0.4")
29    (source (origin
30             (method url-fetch)
31             (uri (string-append
32                   "http://www.brain-dump.org/projects/abduco/abduco-"
33                   version ".tar.gz"))
34             (sha256
35              (base32 "1fxwg2s5w183p0rwzsxizy9jdnilv5qqs647l3wl3khny6fp58xx"))))
36    (build-system gnu-build-system)
37    (arguments
38     `(#:make-flags (list "CC=gcc"
39                          (string-append "PREFIX=" (assoc-ref %outputs "out")))
40       #:phases (modify-phases %standard-phases
41                  (delete 'configure)
42                  (delete 'check)))) ; no test suite
43    (synopsis "Session management in a clean and simple way")
44    (description "abduco provides session management i.e. it allows programs to
45 be run independently from their controlling terminal.  That is, programs can
46 be detached---run in the background---and then later reattached.")
47    (home-page "http://www.brain-dump.org/projects/abduco/")
48    (license isc)))