1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
4 ;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
5 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
7 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
10 ;;; This file is part of GNU Guix.
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
25 (define-module (gnu packages lxqt)
26 #:use-module (guix download)
27 #:use-module ((guix licenses) #:prefix license:)
28 #:use-module (guix packages)
29 #:use-module (guix utils)
30 #:use-module (guix build-system cmake)
31 #:use-module (guix build-system gnu)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages admin)
34 #:use-module (gnu packages compression)
35 #:use-module (gnu packages documentation)
36 #:use-module (gnu packages freedesktop)
37 #:use-module (gnu packages glib)
38 #:use-module (gnu packages gnome)
39 #:use-module (gnu packages gtk)
40 #:use-module (gnu packages image)
41 #:use-module (gnu packages kde)
42 #:use-module (gnu packages kde-frameworks)
43 #:use-module (gnu packages linux)
44 #:use-module (gnu packages perl)
45 #:use-module (gnu packages lxde)
46 #:use-module (gnu packages maths)
47 #:use-module (gnu packages openbox)
48 #:use-module (gnu packages pcre)
49 #:use-module (gnu packages photo)
50 #:use-module (gnu packages pkg-config)
51 #:use-module (gnu packages polkit)
52 #:use-module (gnu packages pulseaudio)
53 #:use-module (gnu packages qt)
54 #:use-module (gnu packages textutils)
55 #:use-module (gnu packages xdisorg)
56 #:use-module (gnu packages xml)
57 #:use-module (gnu packages xorg))
60 ;; Third party libraries
62 (define-public libdbusmenu-qt
64 (name "libdbusmenu-qt")
65 (version "0.9.3+16.04.20160218-0ubuntu1")
69 ;; Download from github rather than launchpad beacuse launchpad trunk
70 ;; tarball hash is not deterministic.
71 (uri (string-append "https://github.com/unity8-team/" name
72 "/archive/" version ".tar.gz"))
74 (base32 "0abwyggnpg50sa9cxphscp5zdkv9nxqnlav55vj21df6q1h3jb5w"))
75 (file-name (string-append name "-" version ".tar.gz"))))
76 (build-system cmake-build-system)
78 ;; XXX: Tests require a dbus session and some icons.
81 `(("doxygen" ,doxygen)))
83 `(("qtbase" ,qtbase)))
84 (home-page "https://launchpad.net/libdbusmenu-qt")
85 (synopsis "Qt implementation of the DBusMenu spec")
86 (description "This library provides a Qt implementation of the DBusMenu
87 protocol. The DBusMenu protocol makes it possible for applications to export
88 and import their menus over DBus.")
89 (license license:lgpl2.1+)))
91 (define-public libstatgrab
98 (uri (string-append "https://ftp.i-scream.org/pub/i-scream/libstatgrab/"
99 name "-" version ".tar.gz"))
101 (base32 "1azinx2yzs442ycwq6p15skl3mscmqj7fd5hq7fckhjp92735s83"))))
102 (build-system gnu-build-system)
104 '(#:configure-flags '("--enable-tests")))
108 (home-page "https://www.i-scream.org/libstatgrab/")
109 (synopsis "Provides access to statistics about the system")
110 (description "libstatgrab is a library that provides cross platform access
111 to statistics about the system on which it's run.")
112 ;; Libraries are under LGPL2.1+, and programs under GPLv2+.
113 (license license:gpl2+)))
118 (define-public lxqt-build-tools
120 (name "lxqt-build-tools")
125 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
126 version "/" name "-" version ".tar.xz"))
128 (base32 "13b5x26p6ycnwzlgg1cgvlc88wjrjmlb3snrrmzh0xgh9h6hhvd6"))))
129 (build-system cmake-build-system)
131 `(#:tests? #f)) ; no tests
133 `(("pkg-config" ,pkg-config)
136 `(("qtbase" ,qtbase)))
137 (synopsis "LXQt Build tools")
139 "Lxqt-build-tools is providing several tools needed to build LXQt
140 itself as well as other components maintained by the LXQt project.")
141 (home-page "https://lxqt.org")
142 (license license:lgpl2.1+)))
144 (define-public libqtxdg
152 "https://github.com/lxqt/" name "/releases/download/"
153 version "/" name "-" version ".tar.xz"))
155 (base32 "0lq548pa69hfvnbj2ypba5ygm8n6v6g7bqqm8p5g538l1l3394cl"))))
156 (build-system cmake-build-system)
160 ,(string-append "-DQTXDGX_ICONENGINEPLUGIN_INSTALL_PATH="
161 %output "/lib/qt5/plugins/iconengines"))
163 (modify-phases %standard-phases
164 (add-before 'check 'pre-check
166 ;; Run the tests offscreen.
167 (setenv "QT_QPA_PLATFORM" "offscreen")
170 ;; required by Qt5XdgIconLoader.pc
173 (home-page "https://github.com/lxqt/libqtxdg")
174 (synopsis "Qt implementation of freedesktop.org xdg specifications")
175 (description "Libqtxdg implements the freedesktop.org xdg specifications
177 (license license:lgpl2.1+)))
179 (define-public liblxqt
187 "https://github.com/lxqt/" name "/releases/download/"
188 version "/" name "-" version ".tar.xz"))
190 (base32 "0fba0nq5b9fvvmklcikcd4nwhzlp5d6k1q1f80r34kncdzfvj7dl"))))
191 (build-system cmake-build-system)
193 `(#:tests? #f ; no tests
195 ;; TODO: prefetch translations files from 'lxqt-l10n'.
196 '("-DPULL_TRANSLATIONS=NO")
198 (modify-phases %standard-phases
199 (add-after 'unpack 'patch-source
201 (substitute* "CMakeLists.txt"
202 (("DESTINATION \"\\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
203 "DESTINATION \"share/polkit-1/actions"))
206 `(("kwindowsystem" ,kwindowsystem)
207 ("libqtxdg" ,libqtxdg)
208 ("libxscrnsaver" ,libxscrnsaver)
209 ("polkit-qt" ,polkit-qt)
211 ("qtx11extras" ,qtx11extras)))
213 `(("lxqt-build-tools" ,lxqt-build-tools)
214 ("qttools" ,qttools)))
215 (home-page "https://lxqt.org/")
216 (synopsis "Core utility library for all LXQt components")
217 (description "liblxqt provides the basic libraries shared by the
218 components of the LXQt desktop environment.")
219 (license license:lgpl2.1+)))
221 (define-public libsysstat
228 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
229 version "/" name "-" version ".tar.xz"))
231 (base32 "0ngz8v3bixsdg96d5ipcyxd6nsrg52974xdxy9rnimahlv1yaxn3"))))
232 (build-system cmake-build-system)
233 (arguments '(#:tests? #f)) ; no tests
235 `(("qtbase" ,qtbase)))
237 `(("lxqt-build-tools" ,lxqt-build-tools)))
238 (home-page "https://lxqt.org/")
239 (synopsis "Library used to query system info and statistics")
240 (description "libsysstat is a library to query system information like CPU
241 and memory usage or network traffic.")
242 (license license:lgpl2.1+)))
247 (define-public lxqt-about
254 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
255 version "/" name "-" version ".tar.xz"))
257 (base32 "08imj7p77ifzfxnn8c482mhrvfx9gi0rb43ab5rw1rkmfvax2n5w"))))
258 (build-system cmake-build-system)
260 `(("kwindowsystem" ,kwindowsystem)
262 ("libqtxdg" ,libqtxdg)
265 ("qtx11extras" ,qtx11extras)))
267 `(("lxqt-build-tools" ,lxqt-build-tools)
268 ("qttools" ,qttools)))
270 '(#:tests? #f ; no tests
272 ;; TODO: prefetch translations files from 'lxqt-l10n'.
273 '("-DPULL_TRANSLATIONS=NO")))
274 (home-page "https://lxqt.org")
275 (synopsis "Provides information about LXQt and the system")
276 (description "lxqt-about is a dialogue window providing information about
277 LXQt and the system it's running on.")
278 (license license:lgpl2.1+)))
280 (define-public lxqt-admin
287 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
288 version "/" name "-" version ".tar.xz"))
290 (base32 "0qvpv668ja83ydbdrlal1596xhag3xlkbd6qlh9xwdpb7nysvns1"))))
291 (build-system cmake-build-system)
293 `(("kwindowsystem" ,kwindowsystem)
295 ("libqtxdg" ,libqtxdg)
296 ("polkit-qt" ,polkit-qt)
298 ("qtx11extras" ,qtx11extras)))
300 `(("lxqt-build-tools" ,lxqt-build-tools)
301 ("qttools" ,qttools)))
303 '(#:tests? #f ; no tests
305 ;; TODO: prefetch translations files from 'lxqt-l10n'.
306 '("-DPULL_TRANSLATIONS=NO")
308 (modify-phases %standard-phases
309 (add-after 'unpack 'patch-source
311 (substitute* "lxqt-admin-user/CMakeLists.txt"
312 (("DESTINATION \"\\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
313 "DESTINATION \"share/polkit-1/actions"))
315 (home-page "https://lxqt.org")
316 (synopsis "LXQt system administration tool")
317 (description "lxqt-admin is providing two GUI tools to adjust settings of
318 the operating system LXQt is running on.")
319 (license license:lgpl2.1+)))
321 (define-public lxqt-config
328 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
329 version "/" name "-" version ".tar.xz"))
331 (base32 "0rizhl2v41kpgp57a61r6nmwcdw8nh9hprrrf33nfrdw8hpwxb95"))))
332 (build-system cmake-build-system)
334 `(("kwindowsystem" ,kwindowsystem)
335 ("libkscreen" ,libkscreen)
337 ("libqtxdg" ,libqtxdg)
338 ("libxcursor" ,libxcursor)
341 ("qtx11extras" ,qtx11extras)
345 `(("pkg-config" ,pkg-config)
346 ("lxqt-build-tools" ,lxqt-build-tools)
347 ("qttools" ,qttools)))
349 '(#:tests? #f ; no tests
351 ;; TODO: prefetch translations files from 'lxqt-l10n'.
352 '("-DPULL_TRANSLATIONS=NO")
354 (modify-phases %standard-phases
355 (add-after 'unpack 'patch-source
357 (substitute* '("src/CMakeLists.txt")
358 (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
359 "DESTINATION \"etc/xdg"))
361 (home-page "https://lxqt.org")
362 (synopsis "Tools to configure LXQt and the underlying operating system")
363 (description "lxqt-config is providing several tools involved in the
364 configuration of both LXQt and the underlying operating system.")
365 (license license:lgpl2.1+)))
367 (define-public lxqt-globalkeys
369 (name "lxqt-globalkeys")
374 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
375 version "/" name "-" version ".tar.xz"))
377 (base32 "1gyvcjbhi7zpvgz1sf773dv9gc35hx5fz023njp9r4vl0dpcavgd"))))
378 (build-system cmake-build-system)
380 `(("kwindowsystem" ,kwindowsystem)
382 ("libqtxdg" ,libqtxdg)
385 ("qtx11extras" ,qtx11extras)))
387 `(("pkg-config" ,pkg-config)
389 ("lxqt-build-tools" ,lxqt-build-tools)))
391 '(#:tests? #f ; no tests
393 ;; TODO: prefetch translations files from 'lxqt-l10n'.
394 '("-DPULL_TRANSLATIONS=NO")
396 (modify-phases %standard-phases
397 (add-after 'unpack 'patch-source
399 (substitute* '("autostart/CMakeLists.txt"
400 "xdg/CMakeLists.txt")
401 (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
402 "DESTINATION \"etc/xdg"))
404 (home-page "https://lxqt.org/")
405 (synopsis "Daemon used to register global keyboard shortcuts")
406 (description "lxqt-globalkeys is providing tools to set global keyboard
407 shortcuts in LXQt sessions, that is shortcuts which apply to the LXQt session
408 as a whole and are not limited to distinct applications.")
409 (license license:lgpl2.1+)))
411 (define-public lxqt-notificationd
413 (name "lxqt-notificationd")
418 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
419 version "/" name "-" version ".tar.xz"))
421 (base32 "1l0hdbvghyhqgvy4pih7rvz26bc6yc8a3l1bdj11hnkw62h1i7d6"))))
422 (build-system cmake-build-system)
424 `(("kwindowsystem" ,kwindowsystem)
426 ("libqtxdg" ,libqtxdg)
429 ("qtx11extras" ,qtx11extras)))
431 `(("lxqt-build-tools" ,lxqt-build-tools)
432 ("qttools" ,qttools)))
434 '(#:tests? #f ; no test target
436 ;; TODO: prefetch translations files from 'lxqt-l10n'.
437 '("-DPULL_TRANSLATIONS=NO")
439 (modify-phases %standard-phases
440 (add-after 'unpack 'patch-source
442 (substitute* '("autostart/CMakeLists.txt")
443 (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
444 "DESTINATION \"etc/xdg"))
446 (home-page "https://lxqt.org/")
447 (synopsis "The LXQt notification daemon")
448 (description "lxqt-notificationd is LXQt's implementation of a daemon
449 according to the Desktop Notifications Specification.")
450 (license license:lgpl2.1+)))
452 (define-public lxqt-openssh-askpass
454 (name "lxqt-openssh-askpass")
459 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
460 version "/" name "-" version ".tar.xz"))
462 (base32 "0l2272gya8jgv71bvg2hz37lnhiznv4ng3j0p6j79f99hwb5ygpk"))))
463 (build-system cmake-build-system)
465 `(("kwindowsystem" ,kwindowsystem)
467 ("libqtxdg" ,libqtxdg)
470 ("qtx11extras" ,qtx11extras)))
472 `(("lxqt-build-tools" ,lxqt-build-tools)
473 ("qttools" ,qttools)))
475 '(#:tests? #f ; no tests
477 ;; TODO: prefetch translations files from 'lxqt-l10n'.
478 '("-DPULL_TRANSLATIONS=NO")))
479 (home-page "https://lxqt.org/")
480 (synopsis "GUI to query passwords on behalf of SSH agents")
481 (description "lxqt-openssh-askpass is a GUI to query credentials on behalf
483 (license license:lgpl2.1+)))
485 (define-public lxqt-panel
492 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
493 version "/" name "-" version ".tar.xz"))
495 (base32 "1qraigzq7nc5a2q6f5ybxwx07gxffa3m3bg7fiv6ppwss51xqfd1"))))
496 (build-system cmake-build-system)
498 `(("alsa-lib" ,alsa-lib)
499 ("kguiaddons" ,kguiaddons)
500 ("kwindowsystem" ,kwindowsystem)
501 ("libdbusmenu-qt" ,libdbusmenu-qt)
503 ("libqtxdg" ,libqtxdg)
504 ("libstatgrab" ,libstatgrab)
505 ("libsysstat", libsysstat)
506 ("libxcomposite" ,libxcomposite)
507 ("libxdamage" ,libxdamage)
508 ("libxkbcommon" ,libxkbcommon)
509 ("libxrender" ,libxrender)
510 ("lm-sensors" ,lm-sensors "lib")
511 ("lxqt-globalkeys" ,lxqt-globalkeys)
513 ("pulseaudio" ,pulseaudio)
516 ("qtx11extras" ,qtx11extras)
518 ("xcb-util" ,xcb-util)))
520 `(("pkg-config" ,pkg-config)
521 ("lxqt-build-tools" ,lxqt-build-tools)
522 ("qttools" ,qttools)))
524 '(#:tests? #f ; no tests
526 ;; TODO: prefetch translations files from 'lxqt-l10n'.
527 '("-DPULL_TRANSLATIONS=NO")
529 (modify-phases %standard-phases
530 (add-after 'unpack 'patch-source
532 (substitute* '("autostart/CMakeLists.txt"
533 "menu/CMakeLists.txt")
534 (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
535 "DESTINATION \"etc/xdg"))
537 (home-page "https://lxqt.org/")
538 (synopsis "The LXQt desktop panel")
539 (description "lxqt-panel represents the taskbar of LXQt.")
540 (license license:lgpl2.1+)))
542 (define-public lxqt-policykit
544 (name "lxqt-policykit")
549 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
550 version "/" name "-" version ".tar.xz"))
552 (base32 "1d97fys6625nk4q6irp0jhsbk30xi7idnii1f3vrrrdcl2cahagp"))))
553 (build-system cmake-build-system)
555 `(("kwindowsystem" ,kwindowsystem)
557 ("libqtxdg" ,libqtxdg)
559 ("polkit-qt" ,polkit-qt)
562 ("qtx11extras" ,qtx11extras)))
564 `(("pkg-config" ,pkg-config)
566 ("lxqt-build-tools" ,lxqt-build-tools)
567 ("qttools" ,qttools)))
569 '(#:tests? #f ; no test target
571 '("-DPULL_TRANSLATIONS=NO")
573 (modify-phases %standard-phases
574 (add-after 'unpack 'patch-source
576 (substitute* '("autostart/CMakeLists.txt")
577 (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
578 "DESTINATION \"etc/xdg"))
580 (home-page "https://lxqt.org/")
581 (synopsis "The LXQt PolicyKit agent")
582 (description "lxqt-policykit is the polkit authentification agent of
584 (license license:lgpl2.1+)))
586 (define-public lxqt-powermanagement
588 (name "lxqt-powermanagement")
593 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
594 version "/" name "-" version ".tar.xz"))
596 (base32 "15nvdypyjwnp7k3d2pkhdbmaqb3ccacmh95rbdbc5mr7yrjy9613"))))
597 (build-system cmake-build-system)
599 `(("kidletime" ,kidletime)
600 ("kwindowsystem" ,kwindowsystem)
602 ("libqtxdg" ,libqtxdg)
605 ("qtx11extras" ,qtx11extras)
608 `(("lxqt-build-tools" ,lxqt-build-tools)
609 ("qttools" ,qttools)))
611 '(#:tests? #f ; no tests
613 ;; TODO: prefetch translations files from 'lxqt-l10n'.
614 '("-DPULL_TRANSLATIONS=NO")
616 (modify-phases %standard-phases
617 (add-after 'unpack 'patch-source
619 (substitute* '("autostart/CMakeLists.txt")
620 (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
621 "DESTINATION \"etc/xdg"))
623 (home-page "https://lxqt.org/")
624 (synopsis "Power management module for LXQt")
625 (description "lxqt-powermanagement is providing tools to monitor power
626 management events and optionally trigger actions like e. g. shut down a system
627 when laptop batteries are low on power.")
628 (license license:lgpl2.1+)))
630 (define-public lxqt-qtplugin
632 (name "lxqt-qtplugin")
637 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
638 version "/" name "-" version ".tar.xz"))
640 (base32 "0nnwbc99njpsyqb0cy3x0srcgwa7qrnq0qwcyx7fbvwsq1l8cz56"))))
641 (build-system cmake-build-system)
643 `(("libdbusmenu-qt" ,libdbusmenu-qt)
644 ("libfm-qt" ,libfm-qt)
645 ("libqtxdg" ,libqtxdg)
648 ("qtx11extras" ,qtx11extras)))
650 `(("lxqt-build-tools" ,lxqt-build-tools)
651 ("qttools" ,qttools)))
653 '(#:tests? #f ; no tests
655 (modify-phases %standard-phases
656 (add-after 'unpack 'patch-source
658 (substitute* '("src/CMakeLists.txt")
659 (("DESTINATION \"\\$\\{QT_PLUGINS_DIR\\}")
660 "DESTINATION \"lib/qt5/plugins"))
662 (home-page "https://lxqt.org/")
663 (synopsis "LXQt Qt platform integration plugin")
664 (description "lxqt-qtplugin is providing a library libqtlxqt to integrate
666 (license license:lgpl2.1+)))
668 (define-public lxqt-runner
675 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
676 version "/" name "-" version ".tar.xz"))
678 (base32 "0dsg6fdcqbl7gza0sg1pb49zn5x31q7zx77jp7mkf6wc2lv8lali"))))
679 (build-system cmake-build-system)
681 `(("kwindowsystem" ,kwindowsystem)
683 ("libqtxdg" ,libqtxdg)
684 ("lxqt-globalkeys" ,lxqt-globalkeys)
685 ("muparser" ,muparser)
689 ("qtx11extras" ,qtx11extras)))
691 `(("pkg-config" ,pkg-config)
693 ("lxqt-build-tools" ,lxqt-build-tools)))
695 '(#:tests? #f ; no tests
697 ;; TODO: prefetch translations files from 'lxqt-l10n'.
698 '("-DPULL_TRANSLATIONS=NO")
700 (modify-phases %standard-phases
701 (add-after 'unpack 'patch-source
703 (substitute* '("autostart/CMakeLists.txt")
704 (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
705 "DESTINATION \"etc/xdg"))
707 (home-page "https://lxqt.org/")
708 (synopsis "Tool used to launch programs quickly by typing their names")
709 (description "lxqt-runner provides a GUI that comes up on the desktop and
710 allows for launching applications or shutting down the system.")
711 (license license:lgpl2.1+)))
713 (define-public lxqt-session
715 (name "lxqt-session")
720 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
721 version "/" name "-" version ".tar.xz"))
723 (base32 "1aibppppmg46ybbajx2qc395l0yp9rqlp2am01fqjxadsf8vci5z"))))
724 (build-system cmake-build-system)
727 ("kwindowsystem" ,kwindowsystem)
729 ("libqtxdg" ,libqtxdg)
732 ("qtx11extras" ,qtx11extras)
733 ("xdg-user-dirs" ,xdg-user-dirs)))
735 `(("pkg-config" ,pkg-config)
736 ("lxqt-build-tools" ,lxqt-build-tools)
737 ("qttools" ,qttools)))
741 `("-DPULL_TRANSLATIONS=NO")
743 (modify-phases %standard-phases
744 (add-after 'unpack 'patch-source
746 (substitute* '("autostart/CMakeLists.txt"
747 "config/CMakeLists.txt")
748 (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
749 "DESTINATION \"etc/xdg"))
751 (home-page "https://lxqt.org/")
752 (synopsis "Session manager for LXQt")
753 (description "lxqt-session provides the standard session manager
754 for the LXQt desktop environment.")
755 (license license:lgpl2.1+)))
757 (define-public lxqt-sudo
764 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
765 version "/" name "-" version ".tar.xz"))
767 (base32 "1j28wlw4rkzvr85yl78fqkvz7sv7dykm9ghm63xdkskfjbsas1cf"))))
768 (build-system cmake-build-system)
770 `(("kwindowsystem" ,kwindowsystem)
772 ("libqtxdg" ,libqtxdg)
775 ("qtx11extras" ,qtx11extras)
778 `(("pkg-config" ,pkg-config)
780 ("lxqt-build-tools" ,lxqt-build-tools)))
782 '(#:tests? #f ; no tests
784 ;; TODO: prefetch translations files from 'lxqt-l10n'.
785 '("-DPULL_TRANSLATIONS=NO")))
786 (home-page "https://lxqt.org/")
787 (synopsis "GUI frontend for sudo/su")
788 (description "lxqt-sudo is a graphical front-end of commands sudo and su
789 respectively. As such it enables regular users to launch applications with
790 permissions of other users including root.")
791 (license license:lgpl2.1+)))
793 (define-public lxqt-themes
800 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
801 version "/" name "-" version ".tar.xz"))
803 (base32 "13kkkzjx8bgnwckz79j273azvm4za66i4cp2qhxwdpxh0fwziklf"))))
804 (build-system cmake-build-system)
806 `(("lxqt-build-tools" ,lxqt-build-tools)))
808 `(#:tests? #f ; no tests
810 (modify-phases %standard-phases
811 (add-after 'unpack 'patch-source
813 (substitute* '("CMakeLists.txt")
814 (("DESTINATION \"\\$\\{LXQT_GRAPHICS_DIR\\}")
815 "DESTINATION \"share/lxqt/graphics"))
816 (substitute* '("themes/CMakeLists.txt")
817 (("DESTINATION \"\\$\\{LXQT_SHARE_DIR\\}")
818 "DESTINATION \"share/lxqt"))
820 (home-page "https://lxqt.org/")
821 (synopsis "Themes, graphics and icons for LXQt")
822 (description "This package comprises a number of graphic files and themes
824 ;; The whole package is released under LGPL 2.1+, while the LXQt logo is
825 ;; licensed under CC-BY-SA 3.0.
826 (license license:lgpl2.1+)))
831 (define-public libfm-qt
838 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
839 version "/" name "-" version ".tar.xz"))
841 (base32 "0p0lbz7dh5c38zq3yp1v1mm99ymg7mqr3h7yzniif2hipmgvxsv9"))))
842 (build-system cmake-build-system)
844 '(#:tests? #f ; no tests
846 ;; TODO : prefetch translations files from 'lxqt-l10n'.
847 '("-DPULL_TRANSLATIONS=NO")))
853 ("menu-cache" ,menu-cache)
856 ("qtx11extras" ,qtx11extras)))
858 `(("pkg-config" ,pkg-config)
859 ("lxqt-build-tools" ,lxqt-build-tools)
860 ("qttools" ,qttools)))
861 (home-page "https://lxqt.org/")
862 (synopsis "Qt binding for libfm")
863 (description "libfm-qt is the Qt port of libfm, a library providing
864 components to build desktop file managers which belongs to LXDE.")
865 (license license:lgpl2.1+)))
867 (define-public pcmanfm-qt
874 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
875 version "/" name "-" version ".tar.xz"))
877 (base32 "08jprkkk62pk34q9lxa207bh27xi86fj8jxfd5z3w2m5j5nim5mz"))))
878 (build-system cmake-build-system)
880 `(("libfm-qt" ,libfm-qt)
882 ("qtx11extras" ,qtx11extras)))
884 `(("pkg-config" ,pkg-config)
886 ("lxqt-build-tools" ,lxqt-build-tools)))
888 '(#:tests? #f ; no tests
890 ;; TODO: prefetch translations files from 'lxqt-l10n'.
891 '("-DPULL_TRANSLATIONS=NO")
893 (modify-phases %standard-phases
894 (add-after 'unpack 'patch-source
896 (substitute* '("autostart/CMakeLists.txt")
897 (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
898 "DESTINATION \"etc/xdg"))
900 (home-page "https://lxqt.org/")
901 (synopsis "File manager and desktop icon manager")
902 (description "PCManFM-Qt is the Qt port of PCManFM, the file manager of
904 (license license:lgpl2.1+)))
909 (define-public compton-conf
911 (name "compton-conf")
916 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
917 version "/" name "-" version ".tar.xz"))
919 (base32 "0q3yx2a6wf8yahrwgvhmv9sd7gmrhid528vrqy04dg8m5cx1bjci"))))
920 (build-system cmake-build-system)
922 `(("libconfig" ,libconfig)
925 `(("lxqt-build-tools" ,lxqt-build-tools)
926 ("pkg-config" ,pkg-config)
927 ("qttools" ,qttools)))
929 '(#:tests? #f ; no tests
931 ;; TODO: prefetch translations files from 'lxqt-l10n'.
932 '("-DPULL_TRANSLATIONS=NO")
934 (modify-phases %standard-phases
935 (add-after 'unpack 'patch-source
937 (substitute* '("autostart/CMakeLists.txt")
938 (("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
939 "DESTINATION \"etc/xdg"))
941 (home-page "https://lxqt.org/")
942 (synopsis "GUI configuration tool for compton X composite manager")
943 (description "@code{compton-conf} is a configuration tool for X composite
945 (license license:lgpl2.1+)))
947 (define-public lximage-qt
954 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
955 version "/" name "-" version ".tar.xz"))
957 (base32 "1mwjh6lrjayr9snsmabkl5qs4xm6d27mfz8k3jxfm5dk3pjj1b0w"))))
958 (build-system cmake-build-system)
960 `(("libexif" ,libexif)
961 ("libfm-qt" ,libfm-qt)
964 ("qtx11extras" ,qtx11extras)))
966 `(("pkg-config" ,pkg-config)
967 ("lxqt-build-tools" ,lxqt-build-tools)
968 ("qttools" ,qttools)))
970 '(#:tests? #f ; no tests
972 ;; TODO: prefetch translations files from 'lxqt-l10n'.
973 '("-DPULL_TRANSLATIONS=NO")))
974 (home-page "https://lxqt.org/")
975 (synopsis "The image viewer and screenshot tool for lxqt")
976 (description "LXImage-Qt is the Qt port of LXImage, a simple and fast
978 (license license:lgpl2.1+)))
980 (define-public obconf-qt
987 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
988 version "/" name "-" version ".tar.xz"))
990 (base32 "1fbzn1p2mdvn8dcbavmd1imrvkph2jfssrlw8l26qz6qk8qlmhnf"))))
991 (build-system cmake-build-system)
1002 ("qtx11extras" ,qtx11extras)))
1004 `(("lxqt-build-tools" ,lxqt-build-tools)
1005 ("pkg-config" ,pkg-config)
1006 ("qttools" ,qttools)))
1008 '(#:tests? #f ; no tests
1010 ;; TODO: prefetch translations files from 'lxqt-l10n'.
1011 '("-DPULL_TRANSLATIONS=NO")))
1012 (home-page "https://lxqt.org/")
1013 (synopsis "Openbox configuration tool")
1014 (description "ObConf-Qt is a Qt port of ObConf, a configuration editor for
1015 window manager OpenBox.")
1016 (license license:gpl2+)))
1018 (define-public pavucontrol-qt
1020 (name "pavucontrol-qt")
1025 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
1026 version "/" name "-" version ".tar.xz"))
1028 (base32 "0pqvhhgw7d00wqw5v3ghm4l8250zy7bqpvhff6l7y1lw0z2fvcp6"))))
1029 (build-system cmake-build-system)
1033 ("pulseaudio" ,pulseaudio)
1035 ("qtx11extras" ,qtx11extras)))
1037 `(("pkg-config" ,pkg-config)
1038 ("lxqt-build-tools" ,lxqt-build-tools)
1039 ("qttools" ,qttools)))
1041 '(#:tests? #f ; no tests
1043 ;; TODO: prefetch translations files from 'lxqt-l10n'.
1044 '("-DPULL_TRANSLATIONS=NO")))
1045 (home-page "https://lxqt.org/")
1046 (synopsis "Pulseaudio mixer in Qt")
1047 (description "@code{pavucontrol-qt} is the Qt port of volume control
1048 @code{pavucontrol} of sound server @code{PulseAudio}.")
1049 (license license:lgpl2.1+)))
1058 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
1059 version "/" name "-" version ".tar.xz"))
1061 (base32 "0pzk83p7a9ax0893s9hp2qkmiilzrf8iqry5a0x1g73hdwm5hm44"))))
1062 (build-system cmake-build-system)
1064 `(("libxrender" ,libxrender)
1066 ("qtx11extras" ,qtx11extras)))
1068 `(("qttools" ,qttools)))
1070 '(#:tests? #f)) ; no tests
1071 (home-page "https://lxqt.org/")
1072 (synopsis "Qt-based visual process status monitor")
1073 (description "@code{qps} is a monitor that displays the status of the
1074 processes currently in existence, much like code{top} or code{ps}.")
1075 (license license:gpl2+)))
1077 (define-public qtermwidget
1079 (name "qtermwidget")
1084 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
1085 version "/" name "-" version ".tar.xz"))
1087 (base32 "1c1qzbysxjbikp4bpgphphw4dgpl10gz8m06ccs2c48qxhpyd773"))))
1088 (build-system cmake-build-system)
1090 `(("qtbase" ,qtbase)))
1092 `(("lxqt-build-tools" ,lxqt-build-tools)
1093 ("qttools" ,qttools)))
1095 '(#:tests? #f ; no tests
1097 ;; TODO: prefetch translations files from 'lxqt-l10n'.
1098 '("-DPULL_TRANSLATIONS=NO")))
1099 (home-page "https://lxqt.org/")
1100 (synopsis "The terminal widget for QTerminal")
1101 (description "QTermWidget is a terminal emulator widget for Qt 5.")
1102 (license license:lgpl2.1+)))
1104 (define-public qterminal
1111 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
1112 version "/" name "-" version ".tar.xz"))
1114 (base32 "1vlza75br1ys62lgkdz26md729bfpbnasfzswp7hakmgaq1rhms1"))))
1115 (build-system cmake-build-system)
1117 `(("qtbase" ,qtbase)
1118 ("qtx11extras" ,qtx11extras)
1119 ("qtermwidget" ,qtermwidget)))
1121 `(("lxqt-build-tools" ,lxqt-build-tools)
1122 ("qttools" ,qttools)))
1124 '(#:tests? #f ; no tests
1126 ;; TODO: prefetch translations files from 'lxqt-l10n'.
1127 '("-DPULL_TRANSLATIONS=NO")))
1128 (home-page "https://lxqt.org/")
1129 (synopsis "Lightweight Qt-based terminal emulator")
1130 (description "QTerminal is a lightweight Qt terminal emulator based on
1132 (license license:lgpl2.1+)))
1134 (define-public screengrab
1141 (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
1142 version "/" name "-" version ".tar.xz"))
1144 (base32 "17y8rsx9fixvxv2byq8d6c01vry10nv07f8jy85vz7zp4f0rgzz3"))))
1145 (build-system cmake-build-system)
1147 `(("kwindowsystem" ,kwindowsystem)
1148 ("libqtxdg" ,libqtxdg)
1151 ("qtx11extras" ,qtx11extras)))
1153 `(("pkg-config" ,pkg-config)
1154 ("qttools" ,qttools)))
1156 '(#:tests? #f)) ; no tests
1157 (home-page "https://lxqt.org/")
1158 (synopsis "Crossplatform tool for fast making screenshots")
1159 (description "ScreenGrab is a program for fast creating screenshots, and
1160 easily publishing them on internet image hosting services.")
1161 (license license:lgpl2.1+)))