New file .my-git-push.
[grutatxt.git] / debian / rules
blobee0cb885bfe06c842e53e9320631c06d3cab96d5
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
15 CFLAGS = -Wall -g
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18 CFLAGS += -O0
19 else
20 CFLAGS += -O2
21 endif
23 configure: configure-stamp
24 configure-stamp:
25 dh_testdir
26 # Add here commands to configure the package.
27 perl Makefile.PL INSTALLDIRS=vendor \
28 INSTALLSCRIPT=/usr/bin
30 touch configure-stamp
33 build: build-stamp
35 build-stamp: configure-stamp
36 dh_testdir
38 # Add here commands to compile the package.
39 $(MAKE)
40 #docbook-to-man debian/grutatxt.sgml > grutatxt.1
42 touch $@
44 clean:
45 dh_testdir
46 dh_testroot
47 rm -f build-stamp configure-stamp
49 # Add here commands to clean up after the build process.
50 -$(MAKE) clean
52 dh_clean
54 install: build
55 dh_testdir
56 dh_testroot
57 dh_clean -k
58 dh_installdirs
60 # Add here commands to install the package into debian/grutatxt.
61 $(MAKE) install DESTDIR=$(CURDIR)/debian/grutatxt
63 # Erase unwanted files created by MakeMaker
64 find $(CURDIR)/debian/grutatxt -type f -name .packlist | xargs rm -f
65 -find $(CURDIR)/debian/grutatxt/usr/lib/perl5 -type d -empty | xargs rmdir -p
67 # Build architecture-independent files here.
68 binary-indep: build install
69 # We have nothing to do by default.
71 # Build architecture-dependent files here.
72 binary-arch: build install
73 dh_testdir
74 dh_testroot
75 # dh_installchangelogs Changelog
76 dh_installdocs
77 dh_installexamples
78 # dh_install
79 # dh_installmenu
80 # dh_installdebconf
81 # dh_installlogrotate
82 # dh_installemacsen
83 # dh_installpam
84 # dh_installmime
85 # dh_python
86 # dh_installinit
87 # dh_installcron
88 # dh_installinfo
89 dh_installman grutatxt.1
90 dh_link
91 dh_strip
92 dh_compress
93 dh_fixperms
94 # dh_perl
95 # dh_makeshlibs
96 dh_installdeb
97 dh_shlibdeps
98 dh_gencontrol
99 dh_md5sums
100 dh_builddeb
102 binary: binary-indep binary-arch
103 .PHONY: build clean binary-indep binary-arch binary install configure