1 DESCRIPTION
= "Gnash is a GNU Flash movie player that supports many SWF v8 features"
2 HOMEPAGE
= "http://www.gnu.org/software/gnash"
4 DEPENDS
= "giflib cairo libtool gtk+ agg libsdl-mixer zlib boost jpeg pango curl freetype \
5 ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'ffmpeg', d)}"
6 DEPENDS
+= "gst-plugins-base"
10 SRC_URI
= "http://www.getgnash.org/packages/snapshots/gnash-trunk.tar.bz2"
12 inherit autotools pkgconfig
14 EXTRA_OECONF
= "--enable-gui=gtk \
15 --enable-renderer=agg \
16 ${@base_conditional('ENTERPRISE_DISTRO', '1', '', '--enable-media=ffmpeg', d)} \
17 --with-plugins-install=system \
19 --disable-dependency-tracking \
21 --enable-media=ffmpeg \
22 --with-cairo-incl=${STAGING_DIR_HOST}/usr/include/cairo \
23 --with-cairo-lib=${STAGING_DIR_HOST}/usr/lib \
24 --with-jpeg-incl=${STAGING_DIR_HOST}/usr/include/ \
25 --with-jpeg-lib=${STAGING_DIR_HOST}/usr/lib \
26 --with-top-level=${STAGING_DIR_HOST}/usr \
29 PACKAGES
=+ " gnash-browser-plugin libgnashamf libgnashbackend libgnashbase libgnashgeo libgnashgui libgnashplayer libgnashserver "
31 FILES_gnash
-browser
-plugin
= "${libdir}/mozilla/plugins/*"
32 FILES_libgnashamf
= "${libdir}/gnash/libgnashamf-${PV}.so"
33 FILES_libgnashbackend
= "${libdir}/gnash/libgnashbackend-${PV}.so"
34 FILES_libgnashbase
= "${libdir}/gnash/libgnashbase-${PV}.so"
35 FILES_libgnashgeo
= "${libdir}/gnash/libgnashgeo-${PV}.so"
36 FILES_libgnashgui
= "${libdir}/gnash/libgnashgui-${PV}.so"
37 FILES_libgnashplayer
= "${libdir}/gnash/libgnashplayer-${PV}.so"
38 FILES_libgnashserver
= "${libdir}/gnash/libgnashserver-${PV}.so"
44 DEFAULT_PREFERENCE
= "-1"
45 DEFAULT_PREFERENCE_angstrom
= "1"
47 # Boost lacks defines
for lots of archs
48 TARGET_CC_ARCH_append
= " -I${STAGING_INCDIR}/libxml2 -DHAVE_POLL_H ${@[' -D_BIG_ENDIAN', ' -D_LITTLE_ENDIAN'][bb.data.getVar('SITEINFO_ENDIANESS', d, 1) == 'le']}"
52 oe_runmake DESTDIR
=$
{D
} install
-plugin