1 gnulib-arch
= $(elfobjdir
)/libgcc-stubs.a
2 static-gnulib-arch
= $(elfobjdir
)/libgcc-stubs.a
5 sysdep-dl-routines
+= tlsdesc dl-tlsdesc
6 sysdep_routines
+= aeabi_unwind_cpp_pr1 find_exidx tlsdesc dl-tlsdesc
7 sysdep-rtld-routines
+= aeabi_unwind_cpp_pr1 tlsdesc dl-tlsdesc
8 shared-only-routines
+= aeabi_unwind_cpp_pr1
10 $(objpfx
)libgcc-stubs.a
: $(objpfx
)aeabi_unwind_cpp_pr1.os
13 lib-noranlib
: $(objpfx
)libgcc-stubs.a
17 # get offset to rtld_global._dl_hwcap
18 gen-as-const-headers
+= rtld-global-offsets.sym tlsdesc.sym
19 aeabi_constants
= aeabi_lcsts aeabi_sighandlers aeabi_math
20 aeabi_routines
= aeabi_assert aeabi_localeconv aeabi_errno_addr \
21 aeabi_mb_cur_max aeabi_atexit aeabi_memclr aeabi_memcpy \
22 aeabi_memmove aeabi_memset
24 sysdep_routines
+= $(aeabi_constants
) $(aeabi_routines
)
25 static-only-routines
+= $(aeabi_constants
)
28 # to pull in __aeabi_read_tp, needed for tls
29 ifeq ($(subdir
),malloc
)
30 $(objpfx
)libmemusage.so
: $(common-objpfx
)libc_nonshared.a
34 sysdep_routines
+= arm-mcount
37 ifeq ($(subdir
),debug
)
38 CFLAGS-backtrace.c
+= -funwind-tables
42 $(objpfx
)libm.so
: $(elfobjdir
)/ld.so