Move all files into ports/ subdirectory in preparation for merge with glibc
[glibc.git] / ports / sysdeps / powerpc / nofpu / Makefile
blob6bdff45465183bd1851dec3b0baca35f3fde4a6b
1 # Makefile fragment for PowerPC with no FPU.
3 ifeq ($(subdir),soft-fp)
4 sysdep_routines += $(gcc-single-routines) $(gcc-double-routines) \
5 sim-full
6 endif
8 ifeq ($(subdir),math)
9 libm-support += fenv_const
10 CPPFLAGS += -I../soft-fp/
11 # The follow CFLAGS are a work around for GCC Bugzilla Bug 29253
12 # "expand_abs wrong default code for floating point"
13 # As this is not a regression, a fix is not likely to go into
14 # gcc-4.1.1 and may be too late for gcc-4.2. So we need these flags
15 # until the fix in a gcc release and glibc drops support for earlier
16 # versions of gcc.
17 CFLAGS-e_powl.c += -fno-builtin-fabsl
18 CFLAGS-s_ccoshl.c += -fno-builtin-fabsl
19 CFLAGS-s_csinhl.c += -fno-builtin-fabsl
20 CFLAGS-s_clogl.c += -fno-builtin-fabsl
21 CFLAGS-s_clog10l.c += -fno-builtin-fabsl
22 CFLAGS-s_csinl.c += -fno-builtin-fabsl
23 CFLAGS-s_csqrtl.c += -fno-builtin-fabsl
24 endif