Move all files into ports/ subdirectory in preparation for merge with glibc
[glibc.git] / ports / sysdeps / m68k / Makefile
blobe2dd3728479e8d092a856c743dd80204c26e657d
1 # Copyright (C) 1993, 1994, 1996, 1997, 2003 Free Software Foundation, Inc.
2 # This file is part of the GNU C Library.
4 # The GNU C Library is free software; you can redistribute it and/or
5 # modify it under the terms of the GNU Lesser General Public
6 # License as published by the Free Software Foundation; either
7 # version 2.1 of the License, or (at your option) any later version.
9 # The GNU C Library is distributed in the hope that it will be useful,
10 # but WITHOUT ANY WARRANTY; without even the implied warranty of
11 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
12 # Lesser General Public License for more details.
14 # You should have received a copy of the GNU Lesser General Public
15 # License along with the GNU C Library. If not, see
16 # <http://www.gnu.org/licenses/>.
18 # The mpn functions need this. All existing 68k ports use MIT syntax. If
19 # a new port wants to use Motorola or Sony syntax, it can redefine this
20 # variable.
21 ifndef m68k-syntax-flag
22 m68k-syntax-flag = -DMIT_SYNTAX
23 endif
25 asm-CPPFLAGS += $(m68k-syntax-flag)
27 pic-ccflag = -fpic
29 # Make sure setjmp.c is compiled with a frame pointer
30 CFLAGS-setjmp.c := -fno-omit-frame-pointer
32 ifeq ($(subdir),elf)
33 CFLAGS-rtld.c += -Wno-uninitialized -Wno-unused
34 endif