Move all files into ports/ subdirectory in preparation for merge with glibc
[glibc.git] / ports / sysdeps / arm / Makefile
blob5fd5136328a0a137ce12db214df2dde5ed4e3fd6
1 ifeq ($(subdir),elf)
2 sysdep-dl-routines += tlsdesc dl-tlsdesc
3 sysdep_routines += aeabi_unwind_cpp_pr1 find_exidx tlsdesc dl-tlsdesc
4 sysdep-rtld-routines += aeabi_unwind_cpp_pr1 tlsdesc dl-tlsdesc
5 shared-only-routines += aeabi_unwind_cpp_pr1
6 endif
8 ifeq ($(subdir),csu)
9 # get offset to rtld_global._dl_hwcap
10 gen-as-const-headers += rtld-global-offsets.sym tlsdesc.sym
11 aeabi_constants = aeabi_lcsts aeabi_sighandlers aeabi_math
12 aeabi_routines = aeabi_assert aeabi_localeconv aeabi_errno_addr \
13 aeabi_mb_cur_max aeabi_atexit aeabi_memclr aeabi_memcpy \
14 aeabi_memmove aeabi_memset
16 sysdep_routines += $(aeabi_constants) $(aeabi_routines)
17 static-only-routines += $(aeabi_constants)
18 endif
20 # to pull in __aeabi_read_tp, needed for tls
21 ifeq ($(subdir),malloc)
22 $(objpfx)libmemusage.so: $(common-objpfx)libc_nonshared.a
23 endif
25 ifeq ($(subdir),gmon)
26 sysdep_routines += arm-mcount
27 endif
29 ifeq ($(subdir),debug)
30 CFLAGS-backtrace.c += -funwind-tables
31 endif
33 ifeq ($(subdir),math)
34 $(objpfx)libm.so: $(elfobjdir)/ld.so
35 endif