Update copyright notices with scripts/update-copyrights.
[glibc.git] / ports / sysdeps / unix / sysv / linux / mips / Makefile
blob66ba621dae1a2827bda5c6e4f2e2d3b2e8dc5494
1 ifeq ($(subdir),signal)
2 #sysdep_routines += sigsuspend
3 endif
5 ifeq ($(subdir),misc)
6 sysdep_routines += cachectl cacheflush sysmips _test_and_set
8 sysdep_headers += sys/cachectl.h sys/sysmips.h sys/tas.h
9 endif
11 # Get value of default-abi.
12 include $(common-objpfx)default-abi.make
14 abi-variants := o32_soft o32_hard n32_soft n32_hard n64_soft n64_hard
16 ifeq (,$(filter $(default-abi),$(abi-variants)))
17 Unknown ABI, must be one of $(abi-variants)
18 endif
20 abi-includes := sgidefs.h
22 # _MIPS_SIM_ABI32 == 1, _MIPS_SIM_NABI32 == 2, _MIPS_SIM_ABI64 == 3
23 abi-o32_soft-options := -U_MIPS_SIM -D_MIPS_SIM=1 \
24 -D__mips_soft_float -U__mips_hard_float
25 abi-o32_soft-condition := defined(__mips_soft_float) \
26 && (_MIPS_SIM == _MIPS_SIM_ABI32)
27 abi-o32_hard-options := -U_MIPS_SIM -D_MIPS_SIM=1 \
28 -D__mips_hard_float -U__mips_soft_float
29 abi-o32_hard-condition := defined(__mips_hard_float) \
30 && (_MIPS_SIM == _MIPS_SIM_ABI32)
31 abi-n32_soft-options := -U_MIPS_SIM -D_MIPS_SIM=2 \
32 -D__mips_soft_float -U__mips_hard_float
33 abi-n32_soft-condition := defined(__mips_soft_float) \
34 && (_MIPS_SIM == _MIPS_SIM_NABI32)
35 abi-n32_hard-options := -U_MIPS_SIM -D_MIPS_SIM=2 \
36 -D__mips_hard_float -U__mips_soft_float
37 abi-n32_hard-condition := defined(__mips_hard_float) \
38 && (_MIPS_SIM == _MIPS_SIM_NABI32)
39 abi-n64_soft-options := -U_MIPS_SIM -D_MIPS_SIM=3 \
40 -D__mips_soft_float -U__mips_hard_float
41 abi-n64_soft-condition := defined(__mips_soft_float) \
42 && (_MIPS_SIM == _MIPS_SIM_ABI64)
43 abi-n64_hard-options := -U_MIPS_SIM -D_MIPS_SIM=3 \
44 -D__mips_hard_float -U__mips_soft_float
45 abi-n64_hard-condition := defined(__mips_hard_float) \
46 && (_MIPS_SIM == _MIPS_SIM_ABI64)
48 ifeq ($(subdir),elf)
49 ifeq ($(build-shared),yes)
50 # This is needed for DSO loading from static binaries.
51 sysdep-dl-routines += dl-static
52 sysdep_routines += dl-static
53 sysdep-rtld-routines += dl-static
54 endif
55 endif
57 ifeq ($(subdir),stdlib)
58 gen-as-const-headers += ucontext_i.sym
59 endif