4 # Uncomment this to turn on verbose mode.
8 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
16 # On PowerPC we compile against the hand-crafted assembly, on all
17 # other architectures we compile against GPL'ed sha1 code lifted
18 # from Mozilla. OpenSSL is strangely licensed and best avoided
21 HOST_ARCH
=$(shell dpkg-architecture
-qDEB_HOST_ARCH
)
22 ifeq (${HOST_ARCH},powerpc
)
23 export PPC_SHA1
=YesPlease
25 export MOZILLA_SHA1
=YesPlease
30 MANDIR
:= /usr
/share
/man
/
34 DESTDIR
:= $(CURDIR
)/debian
/tmp
35 DOC_DESTDIR
:= $(DESTDIR
)/usr
/share
/doc
/git-core
/
36 MAN_DESTDIR
:= $(DESTDIR
)/$(MANDIR
)
38 build
: debian
/build-stamp
41 $(MAKE
) prefix=$(PREFIX
) all doc
42 touch debian
/build-stamp
47 rm -f debian
/build-stamp
59 make DESTDIR
=$(DESTDIR
) prefix=$(PREFIX
) mandir=$(MANDIR
) \
62 mkdir
-p
$(DOC_DESTDIR
)
63 find
$(DOC
) '(' -name
'*.txt' -o
-name
'*.html' ')' -exec
install {} $(DOC_DESTDIR
) ';'
65 dh_movefiles
-p git-tk
66 dh_movefiles
-p git-core
67 find debian
/tmp
-type d
-o
-print | sed
-e
's/^/? /'
69 binary-arch
: build
install
72 dh_installchangelogs
-a
85 binary-indep
: build
install
88 dh_installchangelogs
-i
99 binary
: binary-arch binary-indep
101 .PHONY
: build
clean binary
install clean debian-clean