4 # Uncomment this to turn on verbose mode.
8 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
16 # On PowerPC we compile against the hand-crafted assembly, on all
17 # other architectures we compile against GPL'ed sha1 code lifted
18 # from Mozilla. OpenSSL is strangely licensed and best avoided
21 HOST_ARCH
=$(shell dpkg-architecture
-qDEB_HOST_ARCH
)
22 ifeq (${HOST_ARCH},powerpc
)
23 export PPC_SHA1
=YesPlease
25 export MOZILLA_SHA1
=YesPlease
28 # We do have the requisite perl modules in the mainline, and
29 # have no reason to shy away from this script.
30 export WITH_SEND_EMAIL
=YesPlease
33 MANDIR
:= /usr
/share
/man
/
37 DESTDIR
:= $(CURDIR
)/debian
/tmp
38 DOC_DESTDIR
:= $(DESTDIR
)/usr
/share
/doc
/git-core
/
39 MAN_DESTDIR
:= $(DESTDIR
)/$(MANDIR
)
41 build
: debian
/build-stamp
44 $(MAKE
) prefix=$(PREFIX
) PYTHON_PATH
=/usr
/bin
/python2.4
all test doc
45 touch debian
/build-stamp
50 rm -f debian
/build-stamp
62 make DESTDIR
=$(DESTDIR
) prefix=$(PREFIX
) mandir=$(MANDIR
) \
65 make
-C Documentation DESTDIR
=$(DESTDIR
) prefix=$(PREFIX
) \
66 WEBDOC_DEST
=$(DOC_DESTDIR
) install-webdoc
68 dh_movefiles
-p git-arch
69 dh_movefiles
-p git-cvs
70 dh_movefiles
-p git-svn
71 dh_movefiles
-p git-tk
72 dh_movefiles
-p git-email
73 dh_movefiles
-p git-doc
74 dh_movefiles
-p git-core
75 find debian
/tmp
-type d
-o
-print | sed
-e
's/^/? /'
77 binary-arch
: build
install
80 dh_installchangelogs
-a
93 binary-indep
: build
install
96 dh_installchangelogs
-i
107 binary
: binary-arch binary-indep
109 .PHONY
: build
clean binary
install clean debian-clean