debian: New upstream release v2.9.3
[git/debian.git] / debian / git-el.postinst
blob5ffd7c948e1da5d1f153a17ad0f4bcb0f4f2c5da
1 #!/bin/sh
2 set -e
3 test "$1" = configure || exit 0
4 /usr/lib/emacsen-common/emacs-package-install git
6 # Clean up after 1:1.7.4.1-1 through 1:1.7.4.1-3.
7 ! test -L /usr/share/git-core/emacs/emacs ||
8 rm -f /usr/share/git-core/emacs/emacs
9 ! test -L /usr/share/doc/git/contrib/emacs.old ||
10 rm -f /usr/share/doc/git/contrib/emacs.old
12 # Replace the old /usr/share/doc/git/contrib/emacs directory
13 # with a symlink.
14 test -z "$2" &&
15 ! test -L /usr/share/doc/git/contrib/emacs &&
16 test -d /usr/share/doc/git/contrib/emacs || exit 0
18 if ! rmdir /usr/share/doc/git/contrib/emacs; then
19 echo Moving /usr/share/doc/git/contrib/emacs to emacs.old >&2
20 mv -f /usr/share/doc/git/contrib/emacs /usr/share/doc/git/contrib/emacs.old
22 ln -s ../../../git-core/emacs /usr/share/doc/git/contrib/emacs