debian: apply security fixes from 2.24.1
[git/debian.git] / debian / patches / 0001-t9300-drop-some-useless-uses-of-cat.diff
blobf2d8f8239ea8671b13334451f7d8d969c37596f7
1 From ae664bbeb8f012df1d9ba5334f7c3467304dc2e6 Mon Sep 17 00:00:00 2001
2 From: Jeff King <peff@peff.net>
3 Date: Thu, 29 Aug 2019 11:19:18 -0400
4 Subject: t9300: drop some useless uses of cat
6 These waste a process, and make the line longer than it needs to be.
8 Signed-off-by: Jeff King <peff@peff.net>
9 (cherry picked from commit f94804c1f2626831c6bdf8cc269a571324e3f2f2)
10 Signed-off-by: Jonathan Nieder <jrnieder@gmail.com>
11 ---
12 t/t9300-fast-import.sh | 10 +++++-----
13 1 file changed, 5 insertions(+), 5 deletions(-)
15 diff --git a/t/t9300-fast-import.sh b/t/t9300-fast-import.sh
16 index e707fb861e..6555d38bcc 100755
17 --- a/t/t9300-fast-import.sh
18 +++ b/t/t9300-fast-import.sh
19 @@ -2162,12 +2162,12 @@ test_expect_success 'R: export-marks feature results in a marks file being creat
21 EOF
23 - cat input | git fast-import &&
24 + git fast-import <input &&
25 grep :1 git.marks
28 test_expect_success 'R: export-marks options can be overridden by commandline options' '
29 - cat input | git fast-import --export-marks=other.marks &&
30 + git fast-import --export-marks=other.marks <input &&
31 grep :1 other.marks
34 @@ -2276,7 +2276,7 @@ test_expect_success 'R: import to output marks works without any content' '
35 feature export-marks=marks.new
36 EOF
38 - cat input | git fast-import &&
39 + git fast-import <input &&
40 test_cmp marks.out marks.new
43 @@ -2286,7 +2286,7 @@ test_expect_success 'R: import marks prefers commandline marks file over the str
44 feature export-marks=marks.new
45 EOF
47 - cat input | git fast-import --import-marks=marks.out &&
48 + git fast-import --import-marks=marks.out <input &&
49 test_cmp marks.out marks.new
52 @@ -2594,7 +2594,7 @@ test_expect_success 'R: quiet option results in no stats being output' '
54 EOF
56 - cat input | git fast-import 2> output &&
57 + git fast-import 2>output <input &&
58 test_must_be_empty output
61 --
62 2.24.0.393.g34dc348eaf