debian: comment the debian/rules
[git-cola.git] / debian / rules
blob697a3fcd86c239e3cb92a788c4eafb4d9d610511
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # ugit installs its libraries in /usr/share/ugit/.
10 # A possible wrinkle are the are the .py[co] files.
11 # python 2.5 doesn't seem to care that they were compiled
12 # with 2.4, but YMMV. To solve this we could just
13 # configure+make+make install twice in the install target.
14 # env PYTHON=/usr/bin/python2.4 ./configure ... && .. && ..
15 # env PYTHON=/usr/bin/python2.5 ./configure ... && .. && ..
16 # the only change to support this entails changing ugit's wscript to
17 # install its libraries into:
18 # '/usr/lib/python'+distutils.sysconfig.version+'/site-packages'
19 # instead of '/usr/share/ugit'
21 # Uncomment this to turn on verbose mode.
22 #export DH_VERBOSE=1
24 DEBIAN=$(CURDIR)/debian
25 BUILD=$(DEBIAN)/bld
27 configure: $(BUILD)/configure-stamp
28 $(BUILD)/configure-stamp:
29 ./configure \
30 --prefix=/usr \
31 --blddir=$(BUILD) \
32 --destdir=$(DEBIAN)/ugit
33 touch $(BUILD)/configure-stamp
35 build: $(BUILD)/build-stamp
36 $(BUILD)/build-stamp: $(BUILD)/configure-stamp
37 $(MAKE)
38 touch $(BUILD)/build-stamp
40 clean:
41 dh_testdir
42 dh_testroot
43 dh_clean
44 rm -f $(BUILD)
46 install: build
48 # Build architecture-independent files here.
49 binary-indep: build install
50 dh_testdir
51 dh_testroot
52 dh_clean -k
53 dh_installdirs
54 $(MAKE) DESTDIR=$(DEBIAN)/ugit install
55 dh_fixperms
56 dh_installdeb
57 dh_gencontrol
58 dh_md5sums
59 dh_builddeb
61 binary: binary-indep
62 .PHONY: build clean binary-indep binary install configure