3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
13 # These are used for cross-compiling and for saving the configure script
14 # from having to guess our platform (since we know it already)
15 DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
16 DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
21 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
26 ifeq (,$(findstring nostrip
,$(DEB_BUILD_OPTIONS
)))
30 # shared library versions
31 version
=`ls source/geom/.libs/lib*.so.* | \
32 awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
33 major
=`ls source/geom/.libs/lib*.so.* | \
34 awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
37 # POSTGIS_CONFLICT='-u-DConflicts="libpostgis (<< 0.9.0)"'
41 config.status
: configure
43 # Add here commands to configure the package.
45 .
/configure
--host
=$(DEB_HOST_GNU_TYPE
) --build
=$(DEB_BUILD_GNU_TYPE
) \
46 --prefix=/usr
--mandir=\
$${prefix}/share
/man \
47 --infodir=\
$${prefix}/share
/info
51 build-stamp
: config.status
54 # Add here commands to compile the package.
64 rm -f debian
/shlibs.local
66 # Add here commands to clean up after the build process.
68 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
69 cp
-f
/usr
/share
/misc
/config.sub config.sub
71 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
72 cp
-f
/usr
/share
/misc
/config.guess config.guess
83 # Add here commands to install the package into debian/tmp
84 $(MAKE
) install DESTDIR
=$(CURDIR
)/debian
/tmp
85 $(MAKE
) installcheck DESTDIR
=$(CURDIR
)/debian
/tmp
86 $(CURDIR
)/debian
/makedoc
89 # Build architecture-independent files here.
90 binary-indep
: build
install
91 # We have nothing to do by default.
93 # Build architecture-dependent files here.
94 binary-arch
: build
install
97 dh_installchangelogs ChangeLog
98 dh_installchangelogs debian
/changelog
100 dh_installexamples doc
/example.
cpp
101 dh_movefiles
--sourcedir
=debian
/tmp
#woody uses wildcards in pkg.files
102 # dh_install --sourcedir=$(CURDIR)debian/tmp #woody doesn't use wildcards
105 # dh_installlogrotate
122 dh_gencontrol
$(POSTGIS_CONFLICT
)
126 binary
: binary-indep binary-arch
127 .PHONY
: build
clean binary-indep binary-arch binary
install