net-proxy/clash-verge-bin: Add default USE flag
[gentoo-zh.git] / dev-util / jetbrains-toolbox / jetbrains-toolbox-2.0.3.17006.ebuild
blobdd0d257b29f2b2227e72e3c0f5e57eaa477a2ee4
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Copyright 2019 Rabenda
6 EAPI=8
8 inherit xdg desktop
10 DESCRIPTION="Manage all your JetBrains Projects and Tools"
11 HOMEPAGE="https://www.jetbrains.com/toolbox/app"
12 SRC_URI="https://download.jetbrains.com/toolbox/${P}.tar.gz"
14 LICENSE="JetBrainsToolbox"
15 SLOT="0"
16 KEYWORDS="~amd64"
18 RESTRICT="strip mirror"
20 DEPEND="sys-fs/fuse:0"
22 QA_PREBUILT="opt/jetbrains-toolbox/jetbrains-toolbox"
24 src_compile() {
25 ./"${PN}" --appimage-extract
28 src_install() {
29 keepdir /opt/jetbrains-toolbox
30 insinto /opt/jetbrains-toolbox
31 doins jetbrains-toolbox
33 newicon "${FILESDIR}/${PN}.svg" "${PN}.svg"
35 domenu "${FILESDIR}/${PN}.desktop"
37 fperms +x /opt/jetbrains-toolbox/jetbrains-toolbox