net-proxy/clash-verge-bin: Add default USE flag
[gentoo-zh.git] / dev-cpp / tgbot-cpp / tgbot-cpp-1.3_p220911.ebuild
blob7e2e607a1ede349a1713c14380df094a517aabc5
1 # Copyright 2021-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake git-r3
8 DESCRIPTION="C++ library for Telegram bot API"
9 HOMEPAGE="https://github.com/reo7sp/tgbot-cpp"
10 EGIT_REPO_URI="https://github.com/reo7sp/${PN}.git"
11 EGIT_COMMIT=336a7c5
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE="+shared doc test"
17 RESTRICT="!test? ( test )"
19 DEPEND="
20 sys-libs/zlib
21 dev-libs/openssl
22 >=net-misc/curl-7.56.0
23 >=dev-libs/boost-1.59.0"
24 RDEPEND="${DEPEND}"
25 BDEPEND="doc? ( app-doc/doxygen[dot] )"
27 src_configure() {
28 mycmakeargs=(
29 -DENABLE_TESTS=$(usex test ON OFF)
30 -DBUILD_SHARED_LIBS=$(usex shared ON OFF)
31 -DBUILD_DOCUMENTATION=$(usex doc ON OFF)
33 cmake_src_configure