net-proxy/clash-verge-bin: Add default USE flag
[gentoo-zh.git] / app-i18n / fcitx-skk / fcitx-skk-5.1.0.ebuild
blob04db070c09463e18eb97c03fec7d25129c23df8a
1 # Copyright 2021-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit xdg cmake
8 DESCRIPTION="Japanese SKK input engine for Fcitx5"
9 HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-skk"
10 if [[ "${PV}" =~ (^|\.)9999$ ]]; then
11 inherit git-r3
12 EGIT_REPO_URI="https://github.com/fcitx/fcitx5-skk"
13 SRC_URI=""
14 else
15 KEYWORDS="~amd64 ~x86"
16 MY_PN="fcitx5-skk"
17 MY_P="${MY_PN}-${PV}"
18 S="${WORKDIR}/${MY_PN}-${PV}"
19 SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_P}.tar.xz"
22 LICENSE="GPL-3+"
23 SLOT="5"
25 BDEPEND="kde-frameworks/extra-cmake-modules:5
26 virtual/pkgconfig"
28 RDEPEND="app-i18n/fcitx:5
29 app-i18n/libskk
30 dev-qt/qtcore:5
31 app-i18n/fcitx-qt[qt5,-onlyplugin]
32 app-i18n/skk-jisyo"
33 DEPEND="${RDEPEND}"
35 src_configure() {
36 local mycmakeargs=(
37 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
39 cmake_src_configure