net-dns/dnslookup: add 1.10.1, drop 1.10.0
[gentoo-zh.git] / net-dns / dnslookup / dnslookup-1.10.1.ebuild
blob66a5e5c570456ea4a76eec8a030f215b0203b588
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 inherit go-module
7 DESCRIPTION="Simple command line utility to make DNS lookups to the specified server "
8 HOMEPAGE="https://github.com/ameshkov/dnslookup"
10 SRC_URI="
11 https://github.com/ameshkov/dnslookup/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
12 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-deps.tar.xz
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~arm64"
19 src_compile() {
20 local ldflags="\
21 -X main.VersionString=${PV} \
22 -w -s"
23 ego build -o ${P} -trimpath -ldflags "${ldflags}"
26 src_install() {
27 newbin ${P} dnslookup