media-fonts/Plangothic: add 0.8.5730, drop 0.7.5720
[gentoo-zh.git] / net-proxy / make-proxy / make-proxy-2.0.0.ebuild
blob253572c2b8e54325cf94068ebcb802a3d078d68e
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit systemd
8 DESCRIPTION="Socks5 proxy written in Erlang"
9 HOMEPAGE="https://github.com/yueyoum/make-proxy"
10 SRC_URI="https://github.com/yueyoum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="make-proxy"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="+client server systemd"
17 DEPEND="dev-lang/erlang
18 systemd? ( sys-apps/systemd ) "
19 RDEPEND="${DEPEND}"
21 src_compile() {
22 if use client ; then
23 make client
26 if use server ; then
27 make server
31 src_install() {
32 insinto "/opt/${PN}"
33 doins -r .
35 insinto "/etc/${PN}"
37 if use client ; then
38 newins client.config.example client.config
40 doinitd "${FILESDIR}/mp-client"
43 if use server ; then
44 newins server.config.example server.config
46 doinitd "${FILESDIR}/mp-server"
49 newdoc README.md "${PN}".md
51 if use systemd ; then
52 if use client ; then
53 systemd_dounit "${FILESDIR}/mp-client.service"
56 if use server ; then
57 systemd_dounit "${FILESDIR}/mp-server.service"