net-proxy/v2ray: add 5.16.1, drop 5.15.1
[gentoo-zh.git] / net-proxy / v2ray / v2ray-5.15.3.ebuild
blob29bb093b53ea3e17362b89f78da767cc8703caef
1 # Copyright 2021-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit systemd go-module
8 DESCRIPTION="A platform for building proxies to bypass network restrictions."
9 HOMEPAGE="https://www.v2fly.org/"
10 SRC_URI="https://github.com/v2fly/v2ray-core/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
11 https://github.com/Puqns67/gentoo-deps/releases/download/${P}/${P}-vendor.tar.xz"
13 S="${WORKDIR}/${PN}-core-${PV}"
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
19 RESTRICT="mirror"
21 DEPEND="app-alternatives/v2ray-geoip
22 app-alternatives/v2ray-geosite"
23 RDEPEND="${DEPEND}
24 !net-proxy/v2ray-bin"
25 BDEPEND=">=dev-lang/go-1.21.4"
27 src_prepare() {
28 sed -i 's|/usr/local/bin|/usr/bin|;s|/usr/local/etc|/etc|' release/config/systemd/system/*.service || die
29 sed -i '/^User=/s/nobody/v2ray/;/^User=/aDynamicUser=true' release/config/systemd/system/*.service || die
30 default
33 src_compile() {
34 ego build -o v2ray -trimpath -ldflags "-s -w -buildid=" ./main
37 src_install() {
38 dobin v2ray
40 insinto /etc/v2ray
41 newins release/config/config.json config.json.example
43 newinitd "${FILESDIR}/v2ray.initd-r1" v2ray
44 systemd_dounit release/config/systemd/system/v2ray{,@}.service