app-editors/appflowy-bin: fix overlay.toml
[gentoo-zh.git] / app-editors / appflowy-bin / appflowy-bin-0.0.5.3.ebuild
blob4eee88133bd63eaebc8ee1fe3fb0d03b79d51e5e
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit desktop xdg
8 MY_PN="AppFlowy"
10 DESCRIPTION="AppFlowy is an open-source alternative to Notion"
11 HOMEPAGE="https://www.appflowy.io/"
12 SRC_URI="
13 https://github.com/AppFlowy-IO/AppFlowy/releases/download/${PV}/${MY_PN}_x86_64-unknown-linux-gnu_ubuntu-20.04.tar.gz -> ${P}.tar.gz
16 LICENSE="AGPL-3"
17 SLOT="0"
18 KEYWORDS="-* ~amd64"
20 DEPEND="
21 app-accessibility/at-spi2-core:2
22 dev-libs/glib:2
23 dev-libs/openssl
24 dev-libs/keybinder:3
25 media-libs/harfbuzz
26 media-libs/libepoxy
27 x11-libs/cairo
28 x11-libs/gdk-pixbuf:2
29 x11-libs/gtk+:3
30 x11-libs/pango
32 RDEPEND="${DEPEND}"
34 RESTRICT="mirror test"
36 QA_PRESTRIPPED="
37 /opt/${PN}/lib/libapp.so
38 /opt/${PN}/lib/libflutter_linux_gtk.so
40 QA_PREBUILT="*"
42 S="${WORKDIR}/${MY_PN}_x86_64-unknown-linux-gnu_ubuntu-20.04/${MY_PN}"
44 src_install() {
45 insinto "/opt/${PN}"
46 doins -r data/ lib/ AppFlowy
48 fperms +x /opt/${PN}/AppFlowy
50 sed -i "s#\[CHANGE_THIS\]/AppFlowy#/opt/${PN}#g" appflowy.desktop.temp || die
51 sed -i "s#/opt/${PN}/flowy_logo.svg#flowy_logo#g" appflowy.desktop.temp || die
52 mv appflowy.desktop{.temp,} || die
53 domenu appflowy.desktop
54 doicon -s scalable flowy_logo.svg