net-vpn/tailscale: add 1.66.1, drop 1.64.2
[gentoo-zh.git] / x11-plugins / vicious / vicious-9999.ebuild
blob92587313e8ef53a24a13d0adf1ae8f901d405e5f
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DESCRIPTION="Modular widget library for x11-wm/awesome"
7 HOMEPAGE="http://awesome.naquadah.org/wiki/Vicious"
9 if [[ ${PV} == "9999" ]] ; then
10 inherit git-r3
11 EGIT_REPO_URI="http://git.sysphere.org/${PN}"
12 else
13 SRC_URI="http://git.sysphere.org/${PN}/snapshot/${P}.tar.xz"
14 KEYWORDS="~amd64 ~arm ~x86"
17 LICENSE="GPL-2"
18 SLOT="0"
19 IUSE="contrib"
21 RDEPEND="x11-wm/awesome"
23 src_install() {
24 insinto /usr/share/awesome/lib/vicious
25 doins -r widgets helpers.lua init.lua
26 dodoc CHANGES README TODO
28 if use contrib; then
29 insinto /usr/share/awesome/lib/vicious/contrib
30 doins contrib/*.lua
31 newdoc contrib/README README.contrib