net-vpn/tailscale: add 1.66.1, drop 1.64.2
[gentoo-zh.git] / dev-python / feeluown-bilibili / feeluown-bilibili-0.3.3.ebuild
blob28f3f54a6e22eef3f3012d6dac9e64976d1243ca
1 # Copyright 1999-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 DISTUTILS_USE_PEP517=poetry
6 PYTHON_COMPAT=( python3_{10..11} )
7 PYPI_NO_NORMALIZE=true
8 inherit distutils-r1 pypi
10 DESCRIPTION="bilibili support for feeluown"
11 HOMEPAGE="https://github.com/feeluown/feeluown-bilibili"
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64"
17 RDEPEND="
18 dev-python/beautifulsoup4[${PYTHON_USEDEP}]
19 dev-python/pycryptodome[${PYTHON_USEDEP}]
20 dev-python/cachetools[${PYTHON_USEDEP}]
23 PDEPEND="
24 media-sound/feeluown
27 python_install_all() {
28 distutils-r1_python_install_all