net-vpn/tailscale: add 1.66.1, drop 1.64.2
[gentoo-zh.git] / dev-cpp / tgbot-cpp / tgbot-cpp-1.7.3.ebuild
blobe9ec506a42fce8ab261f7438c5dddcd6bd31ae14
1 # Copyright 2021-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake
8 DESCRIPTION="C++ library for Telegram bot API"
9 HOMEPAGE="https://github.com/reo7sp/tgbot-cpp"
10 SRC_URI="https://github.com/reo7sp/tgbot-cpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~amd64"
15 IUSE="+shared-libs doc test"
16 RESTRICT="!test? ( test )"
18 DEPEND="
19 sys-libs/zlib
20 dev-libs/openssl:=
21 >=net-misc/curl-7.56.0
22 >=dev-libs/boost-1.59.0"
23 RDEPEND="${DEPEND}"
24 BDEPEND="doc? ( app-text/doxygen[dot] )"
26 src_configure() {
27 mycmakeargs=(
28 -DENABLE_TESTS=$(usex test ON OFF)
29 -DBUILD_SHARED_LIBS=$(usex shared-libs ON OFF)
30 -DBUILD_DOCUMENTATION=$(usex doc ON OFF)
32 cmake_src_configure