net-vpn/tailscale: add 1.66.1, drop 1.64.2
[gentoo-zh.git] / dev-cpp / reproc / reproc-14.2.4.ebuild
blob981b4aca7183d7abd62ac645e3846e73b33e8e68
1 # Copyright 2021-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake-multilib
8 DESCRIPTION="A cross-platform (C99/C++11) process library"
9 HOMEPAGE="https://github.com/DaanDeMeyer/reproc"
10 SRC_URI="https://github.com/DaanDeMeyer/reproc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="MIT"
13 SLOT="0/14"
14 KEYWORDS="~amd64 ~arm64 ~x86"
15 IUSE="test"
16 RESTRICT="test"
18 PATCHES=( "${FILESDIR}/${P}-fix-gcc13-build.patch" )
20 multilib_src_configure() {
21 local mycmakeargs=(
22 -DCMAKE_BUILD_TYPE=Release
23 -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
24 -DCMAKE_INSTALL_LIBDIR=$(get_libdir)
25 -DBUILD_SHARED_LIBS=ON
26 -DREPROC++=ON
27 -DREPROC_TEST=$(usex test)
29 cmake_src_configure