net-vpn/tailscale: add 1.66.1, drop 1.64.2
[gentoo-zh.git] / app-i18n / fcitx-gtk / fcitx-gtk-9999.ebuild
blob7ff181005da74661c07b30711dd374caab2280fe
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake gnome2-utils xdg git-r3
7 EGIT_REPO_URI="https://github.com/fcitx/fcitx5-gtk.git"
8 DESCRIPTION="Gtk im module for fcitx5 and glib based dbus client library"
9 HOMEPAGE="https://github.com/fcitx/fcitx5-gtk"
11 LICENSE="LGPL-2.1+"
12 SLOT="5"
13 IUSE="gtk2 +gtk3 +gtk4 +introspection +snooper onlyplugin wayland"
14 REQUIRED_USE="|| ( gtk2 gtk3 gtk4 )"
16 RDEPEND="
17 app-i18n/fcitx:5
18 kde-frameworks/extra-cmake-modules:0
19 gtk2? ( x11-libs/gtk+:2 )
20 gtk3? ( x11-libs/gtk+:3[wayland?] )
21 gtk4? ( gui-libs/gtk:4[wayland?] )
22 introspection? ( dev-libs/gobject-introspection )
24 DEPEND="${RDEPEND}"
25 BDEPEND="
26 virtual/pkgconfig
29 src_configure() {
30 local mycmakeargs=(
31 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
32 -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
33 -DCMAKE_BUILD_TYPE=Release
34 -DENABLE_GTK2_IM_MODULE=$(usex gtk2)
35 -DENABLE_GTK3_IM_MODULE=$(usex gtk3)
36 -DENABLE_GTK4_IM_MODULE=$(usex gtk4)
37 -DENABLE_SNOOPER=$(usex snooper)
38 -DENABLE_GIR=$(usex introspection)
39 -DBUILD_ONLY_PLUGIN=$(usex onlyplugin)
41 cmake_src_configure
44 pkg_postinst() {
45 xdg_pkg_postinst
46 use gtk2 && gnome2_query_immodules_gtk2
47 use gtk3 && gnome2_query_immodules_gtk3
50 pkg_postrm() {
51 xdg_pkg_postrm
52 use gtk2 && gnome2_query_immodules_gtk2
53 use gtk3 && gnome2_query_immodules_gtk3