media-fonts/sarasa-gothic: add 1.0.11, drop 1.0.10
[gentoo-zh.git] / app-i18n / fcitx / fcitx-9999.ebuild
blobf0d3a02fdd3bef87d71d2ee308c4ac3b1716e8cf
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake xdg git-r3
8 EGIT_REPO_URI="https://github.com/fcitx/fcitx5.git"
9 EN_DICT_VER="20121020"
11 DESCRIPTION="Fcitx5 Next generation of fcitx "
12 HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5"
13 SRC_URI=" https://download.fcitx-im.org/data/en_dict-${EN_DICT_VER}.tar.gz -> fcitx-data-en_dict-${EN_DICT_VER}.tar.gz"
15 LICENSE="LGPL-2+ Unicode-DFS-2016"
16 SLOT="5"
17 IUSE="+autostart coverage doc +emoji +enchant +keyboard presage +server systemd test wayland +X"
18 REQUIRED_USE="
19 || ( wayland X )
20 X? ( keyboard )
21 wayland? ( keyboard )
24 RESTRICT="!test? ( test )"
26 RDEPEND="
27 test? (
28 coverage? (
29 dev-util/lcov
33 doc? ( app-text/doxygen )
34 enchant? ( app-text/enchant:2 )
35 emoji? ( sys-libs/zlib )
37 keyboard? (
38 app-text/iso-codes
39 dev-libs/expat
40 dev-libs/json-c:=
41 x11-misc/xkeyboard-config
42 x11-libs/libxkbcommon[X?,wayland?]
45 systemd? ( sys-apps/systemd )
47 wayland? (
48 dev-libs/wayland
49 dev-libs/wayland-protocols
50 dev-util/wayland-scanner
52 X? (
53 x11-libs/libX11
54 x11-libs/libXext
55 x11-libs/libXfixes
56 x11-libs/libXrender
57 x11-libs/libXinerama
58 x11-libs/libxkbfile
59 x11-libs/xcb-util
60 x11-libs/xcb-util-keysyms
61 x11-libs/xcb-util-wm
62 >=x11-libs/xcb-imdkit-1.0.3:5
65 dev-libs/libevent
66 dev-libs/libfmt
67 sys-apps/dbus
68 virtual/libintl
69 x11-libs/gdk-pixbuf:2
70 x11-libs/cairo[X?]
71 x11-libs/pango[X?]
73 DEPEND="${RDEPEND}"
74 BDEPEND="
75 kde-frameworks/extra-cmake-modules:0
76 virtual/pkgconfig
79 src_prepare() {
80 ln -s "${DISTDIR}/fcitx-data-en_dict-${EN_DICT_VER}.tar.gz" src/modules/spell/en_dict-${EN_DICT_VER}.tar.gz || die
81 cmake_src_prepare
84 src_configure() {
85 local mycmakeargs=(
86 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
87 -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
88 -DENABLE_DBUS=on
89 -DENABLE_XDGAUTOSTART=$(usex autostart)
90 -DENABLE_SERVER=$(usex server)
91 -DENABLE_KEYBOARD=$(usex keyboard)
92 -DENABLE_TEST=$(usex test)
93 -DENABLE_COVERAGE=$(usex coverage)
94 -DENABLE_ENCHANT=$(usex enchant)
95 -DENABLE_EMOJI=$(usex emoji)
96 -DENABLE_PRESAGE=$(usex presage)
97 -DENABLE_WAYLAND=$(usex wayland)
98 -DENABLE_X11=$(usex X)
99 -DENABLE_DOC=$(usex doc)
100 -DUSE_SYSTEMD=$(usex systemd)
102 cmake_src_configure
105 src_test() {
106 # break by sandbox
107 local CMAKE_SKIP_TESTS=(
108 testdbus
109 testservicewatcher
111 cmake_src_test
114 pkg_postinst() {
115 xdg_pkg_postinst
117 elog
118 elog "Follow the instrcutions on:"
119 elog "https://wiki.gentoo.org/wiki/Fcitx#Using_Fcitx"
120 elog "https://fcitx-im.org/wiki/Setup_Fcitx_5"
121 elog "https://fcitx-im.org/wiki/Using_Fcitx_5_on_Wayland"
122 elog