app-office/wps-office: update RDEPEND usage with >=app-emulation/liblol-0.1
[gentoo-zh.git] / www-servers / woof / woof-9999.ebuild
blobd413e14408dc680ec7d723a68d7a4bc0d647ea83
1 # Copyright 2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 PYTHON_COMPAT=( python3_{9..11} )
8 inherit git-r3 python-single-r1
10 DESCRIPTION="an ad-hoc single file webserver"
11 HOMEPAGE="http://www.home.unix-ag.org/simon/woof.html https://github.com/simon-budig/woof"
12 EGIT_REPO_URI="https://github.com/simon-budig/${PN}.git"
14 LICENSE="GPL-2"
15 SLOT="0"
16 #KEYWORDS="~amd64 ~x86"
18 IUSE="+gzip +bzip2 +unzip"
19 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
21 DEPEND="
22 gzip? ( app-arch/gzip )
23 bzip2? ( app-arch/bzip2 )
24 unzip? ( app-arch/unzip )
27 RDEPEND="
28 ${DEPEND}
29 ${PYTHON_DEPS}
32 src_install(){
33 python_doscript ${PN}