app-office/wps-office: update RDEPEND usage with >=app-emulation/liblol-0.1
[gentoo-zh.git] / app-misc / rmtrash / rmtrash-1.14.ebuild
blobef93958b41b73dfb91cf094e72081fa313e271c8
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 DESCRIPTION="trash-put made compatible to GNUs rm and rmdir"
7 HOMEPAGE="https://github.com/PhrozenByte/rmtrash"
8 SRC_URI="https://github.com/PhrozenByte/rmtrash/archive/v${PV}.tar.gz -> ${PN}-${PV}.tar.gz"
10 LICENSE="GPL-3"
11 SLOT="0"
12 KEYWORDS="~amd64"
14 RESTRICT="mirror"
16 RDEPEND="app-misc/trash-cli"
18 src_install() {
19 insinto /usr/bin
20 insopts -m755
21 doins rmtrash
22 doins rmdirtrash
25 pkg_postinst() {
26 elog "It is suggested to add following code into ~/.bashrc:"
27 elog "--------------------------------------------------------------------"
28 elog " alias rm='rmtrash'"
29 elog " alias rmdir='rmdirtrash'"
30 elog " alias sudo='sudo '"
31 elog "--------------------------------------------------------------------"
32 elog "see https://github.com/PhrozenByte/rmtrash for more information"