x11-themes/fcitx-breeze: update nvchecker
[gentoo-zh.git] / app-misc / gpick / gpick-0.3.ebuild
blobcf38cd30e0a88915fae364ba0a9865450d5b7e98
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake xdg
8 DESCRIPTION="Advanced color picker written in C++ using GTK+ toolkit"
9 HOMEPAGE="https://github.com/thezbyg/gpick"
10 SRC_URI="https://github.com/thezbyg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="+gtk3 nls"
16 RDEPEND="
17 >=dev-lang/lua-5.2:=
18 dev-libs/boost
19 dev-libs/expat
20 dev-util/ragel
21 nls? ( sys-devel/gettext )
22 gtk3? ( x11-libs/gtk+:3 )
23 !gtk3? ( x11-libs/gtk+:2 )
26 DEPEND="${RDEPEND}"
28 PATCHES=( "${FILESDIR}/gpick-libc.patch" )
30 src_prepare() {
31 cp "${FILESDIR}/.version" . || die
32 cmake_src_prepare
35 src_configure() {
36 local mycmakeargs=(
37 -DUSE_GTK3=$(usex gtk3 ON OFF)
38 -DENABLE_NLS=$(usex nls ON OFF)
40 cmake_src_configure
43 src_install() {
44 cmake_src_install
46 mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${PF}" || die