Merge pull request #3446 from gouwazi/bump
[gentoo-zh.git] / net-dns / q / q-0.11.1.ebuild
blobd822bd38b74a4e4f04f7bb910a1599ab5cdd5ce2
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 inherit go-module
6 GIT_COMMIT=15b493d0
8 DESCRIPTION="A tiny command line DNS client with support for UDP, TCP, DoT, DoH, DoQ and ODoH"
9 HOMEPAGE="https://github.com/natesales/q"
11 SRC_URI="
12 https://github.com/natesales/q/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
13 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-deps.tar.xz
16 DEPEND=""
17 RDEPEND="${DEPEND}"
18 LICENSE="GPL-3"
19 SLOT="0"
20 KEYWORDS="~amd64 ~arm64"
21 IUSE=""
23 src_compile() {
24 local ldflags="\
25 -X main.version=${PV} \
26 -X main.commit=${GIT_COMMIT} \
27 -X main.date=$(date -u +%Y-%m-%dT%H:%M:%SZ) \
28 -w -s"
29 ego build -o ${P} -trimpath -ldflags "${ldflags}"
32 src_install() {
33 newbin ${P} q-dns