clean cvs header
[gentoo-zh.git] / www-plugins / upeditor / upeditor-1.0.0.6.ebuild
blobbfaeeeda20d6b01d878de7a98fa7b1df9beadbf2
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v3
4 EAPI=6
7 inherit nsplugins
9 #MY_PV="$(get_version_component_range 1-2)"
11 DESCRIPTION="unionpay security control plugin"
12 HOMEPAGE="https://online.unionpay.com/"
13 KEYWORDS="~amd64 ~x86"
14 SRC_URI="x86? ( ${HOMEPAGE}/mer/resources/js/ocx/UPEditorLinux.tar.bz2 )
15 amd64? ( ${HOMEPAGE}/mer/resources/js/ocx/UPEditorLinux64.tar.bz2 )"
17 LICENSE="unknown"
18 RESTRICT="strip mirror"
19 SLOT="0"
20 IUSE=""
22 RDEPEND="dev-libs/openssl"
23 DEPEND="${RDEPEND}"
25 S=${WORKDIR}
27 src_prepare() {
28 addwrite /var/lib/installjammer
29 #addpredict /var/lib/installjammer
31 use amd64 && ./UPEditor-1.0-Linux-x86_64-Install --mode silent \
32 --prefix ${S} --temp ${S}/tmp
33 use x86 && ./UPEditor-1.0-Linux-x86-Install --mode silent \
34 --prefix ${S} --temp ${S}/tmp
37 src_install() {
38 insinto "/opt/netscape/plugins"
39 doins "${WORKDIR}"/libnpUPEditor.so
40 inst_plugin /opt/netscape/plugins/libnpUPEditor.so
42 rm -rf "${ROOT}"/var/lib/installjammer || die