clean cvs header
[gentoo-zh.git] / sys-libs / libixp / libixp-9999.ebuild
blob4c8a0c73f9914d7d3ea1025ecff53e07cc031197
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 inherit toolchain-funcs mercurial
6 DESCRIPTION="Standalone client/server 9P library"
7 HOMEPAGE="http://libs.suckless.org/"
8 EHG_REPO_URI="http://code.suckless.org/hg/libixp"
10 LICENSE="MIT"
11 SLOT="0"
12 KEYWORDS="~amd64 ~ppc64 ~x86"
13 IUSE=""
15 DEPEND=""
16 RDEPEND=""
18 S="${WORKDIR}/${PN}"
20 src_unpack() {
21 mercurial_src_unpack
23 sed -i \
24 -e "/^ *PREFIX/s|=.*|= /usr|" \
25 -e "/^ *ETC/s|=.*|= /etc|" \
26 -e "/^ *CFLAGS/s|=|+=|" \
27 -e "/^ *LDFLAGS/s|=|+=|" \
28 "${S}"/config.mk || die "sed failed"
31 src_compile() {
32 emake -j1 || die "emake failed"
35 src_install() {
36 emake -j1 DESTDIR="${D}" install || die "emake install failed"