clean cvs header
[gentoo-zh.git] / net-libs / jzmq / jzmq-9999.ebuild
bloba7120c56787ff77a90efd79f21b0848593b84b3d
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 DESCRIPTION="jzmq"
5 HOMEPAGE="http://www.zeromq.org/bindings:java"
7 if [[ ${PV} == "9999" ]] ; then
8 EGIT_REPO_URI="https://github.com/zeromq/jzmq.git"
9 vcs=git-r3
10 else
11 SRC_URI=""
12 KEYWORDS="~amd64 ~x86"
15 LICENSE="LGPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
18 IUSE=""
20 RDEPEND=""
21 DEPEND="net-libs/zeromq"
23 src_prepare() {
24 eaclocal
25 eautoconf
28 src_configure() {
29 echo "configure"
30 PATH=/etc/java-config-2/current-system-vm/bin:$PATH
31 PKG_CONFIG=/usr/lib64/pkgconfig/
32 eautomake
33 econf
34 make
37 src_install() {
38 emake DESTDIR="${D}" install || die "emake install failed"
39 dodoc README ChangeLog || die "dodoc failed"