clean cvs header
[gentoo-zh.git] / dev-libs / lunar-date / lunar-date-2.4.2.ebuild
blob3ea0a184330eb5e80665143f547e859bb68d27fe
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3 EAPI=6
5 inherit autotools
7 DESCRIPTION="Chinese Lunar Library"
8 HOMEPAGE="http://github.com/yetist/lunar-date"
9 SRC_URI="http://github.com/yetist/lunar-date/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="x86 amd64"
14 IUSE="doc python"
16 RDEPEND="${RDEPEND}
17 python? ( >=dev-python/pygobject-2.11.5 )"
19 DEPEND="${RDEPEND}
20 sys-devel/gettext
21 virtual/pkgconfig
22 >=dev-util/intltool-0.35
23 doc? ( dev-util/gtk-doc )
24 >=app-text/gnome-doc-utils-0.3.2"
26 DOCS="AUTHORS ChangeLog NEWS README"
28 src_prepare() {
29 eapply_user
30 ./autogen.sh || die "autoconf failed"
33 src_configure(){
34 econf $(use_enable python) $(use_enable doc) || die "compile failed"
37 src_compile(){
38 emake
41 src_install() {
42 emake DESTDIR="${D}" install || die "make install failed"