clean cvs header
[gentoo-zh.git] / dev-libs / libdwarf / libdwarf-20140208.ebuild
blobf88e8627f15888c298cd082a0675720bbffed929
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit eutils flag-o-matic
8 DESCRIPTION="Library to deal with DWARF Debugging Information Format"
9 HOMEPAGE="https://github.com/Distrotech/libdwarf"
10 SRC_URI="https://github.com/Distrotech/${PN}/archive/${PV}.tar.gz"
12 LICENSE="GPL-2 LGPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
17 DEPEND=""
18 RDEPEND="${DEPEND}"
20 S="${WORKDIR}/${P}/${PN}"
22 # dirty hack, since I can't properly patch buildsystem
23 QA_PREBUILT="*/${PN}.so"
25 src_configure() {
26 econf --enable-shared
29 src_install() {
30 dolib.a libdwarf.a || die
31 dolib.so libdwarf.so || die
33 insinto /usr/include
34 doins libdwarf.h || die
36 dodoc NEWS README CHANGES || die