clean cvs header
[gentoo-zh.git] / app-vim / icomplete / icomplete-0.4.ebuild
blob5a00c44209910aefd406a6d51ee7764684f47e17
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 inherit vim-plugin
6 DESCRIPTION="vim plugin: an c/c++ auto-completion plugin that supports c#/java partually."
7 HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1265 http://icomplete.sourceforge.net"
8 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
10 LICENSE="GPL-2"
11 KEYWORDS="~amd64 x86"
12 IUSE=""
14 DEPEND="app-editors/vim"
15 RDEPEND="dev-util/ctags"
17 VIM_PLUGIN_HELPFILES=""
18 VIM_PLUGIN_HELPTEXT=""
19 VIM_PLUGIN_HELPURI=""
20 VIM_PLUGIN_MESSAGES=""
22 src_unpack() {
23 unpack ${A}
25 cd ${WORKDIR}/${P}
26 sed 's/CFLAGS="${CFLAGS} -O2 /CFLAGS="${CFLAGS} /g' configure > configure.new
27 cat configure.new > configure
28 rm configure.new
31 src_compile() {
32 # econf doesn't work, because this pkg use tconf framework.
33 ./configure --prefix=/usr CTAGS_CMD=exuberant-ctags
34 emake
37 src_install() {
38 emake DESTDIR="${D}" install