clean cvs header
[gentoo-zh.git] / app-text / xdvipdfmx / xdvipdfmx-9999.ebuild
blobd1a35b1512493cf57176483d0d2a5f9df02b433e
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit eutils subversion
8 DESCRIPTION="Extended xdvi for use with XeTeX and other unicode TeXs."
9 HOMEPAGE="http://scripts.sil.org/svn-view/xdvipdfmx/"
10 ESVN_REPO_URI="http://scripts.sil.org/svn-public/${PN}/TRUNK"
11 LICENSE="GPL-2-with-linking-exception"
12 SLOT="0"
13 KEYWORDS=""
14 IUSE=""
16 DEPEND=">=media-libs/freetype-2.0
17 virtual/latex-base
20 src_compile() {
21 econf \
22 --with-ft2lib=/usr/$(get_libdir)/libfreetype.so \
23 --with-ft2include=/usr/include/freetype2 || die "econf failed"
25 emake || die "emake failed"
28 src_install() {
29 emake DESTDIR="${D}" install || die "Install failed"
30 dodoc README doc/tug2003.pdf doc/CJK-CID.txt doc/images/dvipdfm-cjk.png doc/images/dvipdfmx-logo.png doc/images/rightarrow.png doc/images/right_triangle.png doc/images/dvipdfmx.png TODO BUGS AUTHORS