clean cvs header
[gentoo-zh.git] / app-text / openyoudao / openyoudao-9999.ebuild
blob86063f3e86fe30051d53f086c2f07934590bfb43
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit git-r3
8 DESCRIPTION="openyoudao is a youdao client for linux."
9 HOMEPAGE="http://openyoudao.org"
11 EGIT_REPO_URI="https://github.com/justzx2011/openyoudao.git"
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~x86 ~amd64"
16 IUSE=""
18 DEPEND="x11-misc/xclip
19 dev-python/pywebkitgtk
20 dev-python/python-xlib
21 dev-python/lxml
22 dev-python/beautifulsoup"
24 RDEPEND="${DEPEND}"
26 src_prepare(){
27 sed -i '1,5s/BeautifulSoup/bs4/' fusionyoudao.py || die "patch error"
30 src_install(){
31 insinto /usr/bin
32 dobin ${S}/scripts/openyoudao || die "Install failed"
34 insinto /usr/lib/openyoudao
35 doins ${S}/*.py || die "lib install failed"
37 insinto /usr/share/openyoudao
38 doins -r ${S}/cache/* || die "cache install failed"
40 insinto /usr/share/applications
41 doins ${S}/desktop/openyoudao.desktop || die "desktop link install failed"