clean cvs header
[gentoo-zh.git] / app-misc / bcompare / bcompare-4.2.2.22384.ebuild
blob98778629c3ae2428df4b6a0590c72befbaf45dd4
1 # Copyright 2016-2021 Chun-Yu Lee (Mat) <matlinuxer2@gmail.com>
2 # Distributed under the terms of the MIT License
4 EAPI=7
6 inherit eutils user
8 DESCRIPTION="Beyond Compare -- Compare, sync, and merge files and folders"
9 HOMEPAGE="http://www.scootersoftware.com/"
10 SRC_URI="
11 x86? ( http://www.scootersoftware.com/bcompare-${PV}.i386.tar.gz )
12 amd64? ( http://www.scootersoftware.com/bcompare-${PV}.x86_64.tar.gz )"
14 LICENSE="Bcompare"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE=""
18 RESTRICT="mirror"
19 RDEPEND="
20 dev-qt/qtgui:4
21 dev-qt/qtcore:4
25 src_unpack() {
26 unpack ${A}
29 src_install() {
30 local targetdir="/opt/bcompare"
31 local LAUNCHER="bcompare/bin/bcompare"
33 insinto "${targetdir}"
34 sed -i ./install.sh -e 's/^# Create desktop entry and place.*/exit 0/g'
35 sed -i ./install.sh -e "s%^# Copy the files.*%BC_BIN=\"$D/\$BC_BIN\"; BC_LIB=\"$D/\$BC_LIB\";%g"
36 sed -i ./install.sh -e "s/^\texit 1.*//g"
37 ./install.sh --prefix="${targetdir}"
39 dodir /opt/bin
40 dosym /opt/${LAUNCHER} /opt/bin/${LAUNCHER/*bin\/}