clean cvs header
[gentoo-zh.git] / app-i18n / scim-array / scim-array-1.0.1.ebuild
blobbf2575f17f5831a157948a700ae6b2efef30e0e8
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 inherit eutils
6 DESCRIPTION="Array Input Method for SCIM"
7 HOMEPAGE="http://scimarray.openfoundry.org/"
8 SRC_URI="http://of.openfoundry.org/download_path/scimarray/${PV}/${P}.tar.gz"
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="x86 ~amd64"
13 IUSE=""
15 DEPEND=">=app-i18n/scim-1.4"
17 src_compile() {
18 econf || die
19 emake || die
22 src_install() {
23 make DESTDIR=${D} install || die "make install failed"
25 dodoc AUTHORS THANKS README
28 pkg_postinst() {
29 einfo
30 einfo "To use SCIM with both GTK2 and XIM, you should use the following"
31 einfo "in your user startup scripts such as .gnomerc or .xinitrc:"
32 einfo
33 einfo "LANG='your_language' scim -d"
34 einfo "export XMODIFIERS=@im=SCIM"
35 einfo