clean cvs header
[gentoo-zh.git] / app-i18n / hime / hime-0.9.10.ebuild
blobeb3781f3d7c72579c0b0070ebf78ae260d4247fe
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
5 inherit eutils toolchain-funcs flag-o-matic
7 DESCRIPTION="HIME Input Method Editor"
8 HOMEPAGE="http://hime.luna.com.tw/"
9 SRC_URI="http://hime.luna.com.tw/hime-${PV}.tar.xz
10 chinese-sound? ( http://www.csie.nctu.edu.tw/~cp76/hime/download/ogg.tgz )"
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~x86 ~amd64"
15 IUSE="filter-nobopomofo chinese-sound anthy chewing gtk3 qt4"
17 DEPEND=">=x11-libs/gtk+-2
18 anthy? ( >=app-i18n/anthy-9100 )
19 chewing? ( dev-libs/libchewing )
20 gtk3? ( x11-libs/gtk+:3 )
21 qt4? ( dev-qt/qtcore:4 dev-qt/qtgui )"
22 RDEPEND="${DEPEND}
23 chinese-sound? ( media-sound/vorbis-tools[ogg123] )"
24 DEPEND="${DEPEND}
25 virtual/pkgconfig
26 sys-devel/gettext"
28 RESTRICT="mirror"
29 S=${WORKDIR}/${P/_/.}
31 src_prepare() {
32 echo "${P}" > ${S}/VERSION.hime
35 src_configure() {
36 econf --use_i18n=Y \
37 --use_tsin=Y \
38 --use_qt3=N \
39 $(! use anthy && echo --use_anthy=N ) \
40 $(! use chewing && echo --use_chewing=N ) \
41 $(! use qt4 && echo --use_qt4=N ) \
42 $(! use gtk3 && echo --use_gtk3=N )
45 src_compile() {
46 filter-ldflags "-Wl,--as-needed"
47 MAKEOPTS="${MAKEOPTS} -j1" emake CC="$(tc-getCC)" || die
50 src_install() {
51 emake DESTDIR="${D}" install || die
53 if use filter-nobopomofo ; then
54 insinto /usr/share/pixmaps/hime
55 doins "${FILESDIR}"/nobopomofo/{SS1135_ST,SS1208_DT}.jpg || die
56 exeinto /usr/share/hime/script
57 doexe "${FILESDIR}"/nobopomofo/hime-filter-nobopomofo || die
58 doenvd "${FILESDIR}"/nobopomofo/99hime-filter-nobopomofo || die
61 if use chinese-sound ; then
62 insinto /usr/share/${PN}
63 doins -r "${WORKDIR}"/ogg || die