net-dns/dnslookup: new package, add 1.9.1
[gentoo-zh.git] / app-emulation / deepin-wine-plugin / deepin-wine-plugin-5.1.13-r1.ebuild
blob94010b519773bb2966a7ad1e56bd4b28b858c03e
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 PYTHON_COMPAT=( python3_{9..11} )
7 inherit unpacker python-r1
9 DESCRIPTION="Deepin Wine plugin"
10 HOMEPAGE="https://www.deepin.org"
12 COMMON_URI="https://cdn-package-store6.deepin.com/appstore/pool/appstore/d"
13 SRC_URI="${COMMON_URI}/deepin-wine-helper/${PN}_${PV}-${PR/r/}_amd64.deb
14 virtual-pkg? ( ${COMMON_URI}/deepin-wine-helper/${PN}-virtual_${PV}-${PR/r/}_all.deb )"
16 LICENSE="LGPL-2.1"
17 SLOT="0"
18 KEYWORDS="~amd64"
19 IUSE="+virtual-pkg"
21 DEPEND=""
22 RDEPEND="${DEPEND}
23 virtual-pkg? (
24 app-arch/p7zip
25 $(python_gen_cond_dep '
26 dev-python/pydbus[${PYTHON_USEDEP}]
31 S=${WORKDIR}
33 QA_PREBUILT="/usr/lib/i386-linux-gnu/deepin-wine* /usr/share/doc/*"
34 QA_FLAGS_IGNORED="/usr/lib/i386-linux-gnu/deepin-wine* /usr/share/doc/*"
36 src_install() {
37 insinto /
38 doins -r usr