Merge pull request #1262 from HougeLangley/master
[gentoo-zh.git] / net-misc / pcmanx-gtk2 / pcmanx-gtk2-9999.ebuild
blob3ae8203c09f3bd981defc661e21c9392e35104dd
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit autotools flag-o-matic git-r3
8 DESCRIPTION="PCMan is a gtk+ based free BBS client"
9 HOMEPAGE="https://github.com/pcman-bbs/pcmanx"
10 EGIT_REPO_URI="${HOMEPAGE}.git"
12 KEYWORDS=""
13 SLOT="0"
14 LICENSE="GPL-2"
15 IUSE="+libnotify +proxy iplookup +wget"
17 COMMON_DEPEND="
18 libnotify? ( x11-libs/libnotify )
19 x11-libs/libXft
20 >=x11-libs/gtk+-2.4:*
23 RDEPEND="
24 ${COMMON_DEPEND}
25 wget? ( net-misc/wget )
28 DEPEND="
29 ${COMMON_DEPEND}
30 dev-util/intltool
31 sys-devel/gettext
34 src_prepare() {
35 [[ ! -e ChangeLog && -e ./build/changelog.sh ]] && \
36 ./build/changelog.sh > ChangeLog
37 intltoolize --copy --force --automake || die "intltoolize failed"
38 eautoreconf
40 # this flag crashes CTermData::memset16()
41 filter-flags -ftree-vectorize
42 eapply_user
45 src_configure() {
46 econf $(use_enable proxy) \
47 $(use_enable libnotify) \
48 $(use_enable wget)\
49 $(use_enable iplookup)